Phnx MT202pcs Speaker Phone gives Error in playback & record

The Phnx MT202pcs Speaker Phone gives Error while opening sound device when chosen for both playback & record in Audacity 2.1.0 on both a MacBook Pro 12,1 (Early 2015) and a Mac Pro 4,1 (Early 2009), each running El Capitan. By contrast, if other sound devices (such as built in or HD Pro Webcam C920) are used, there is no problem.

Apple (upper left desktop) > System Preferences > Sound > Input (or output). Does the speakerphone show up there?

Audacity gets its devices from the operating system and computer. If they can’t see it, that’s the end of the story.


Yes, the speaker phone shows up both in the input and output lists of the sound section of the preferences, in each case it is Phnx MT202pcs. It also shows up within Audacity itself within both the recording device and playback device dropdown menus.

If you still receive “Error opening sound device” you could go into /Applications/Utilities/Audio MIDI Setup, make the device the default input and output device, and for both input and output, set the sample rate to be the same as the Audacity project rate (bottom left of Audacity).

The rate of the Audacity tracks might need to be the same as the project rate too.

The web page for the device says it is full duplex, meaning that it is supposed to be able to play and record at the same time.


The instructions tell me this is a cousin of a videoconferencing system I’ve used in the past, however, the conferencing system and the sound system were a married couple, so we didn’t have to do much adjusting, and they did work just fine.

We did publish a piece on this error.

I know you can get into trouble with as simple an error as the stereo/mono is set wrong in the recording drop-down. Some systems don’t care, some do.

Write back how you made out. I don’t think anybody has posted with one of these before. And yes, they are full duplex, built for real-time videoconferences.


The attached screenshot shows the error after trying the posted suggestions. Nothing worked, unfortunately. Note in the screenshot that

  1. The Phnx MT202pcs speaker phone is already set as the default for input / output
  2. Audacity is set at the same project rate (32000) as in the Midi set up (it also happened when the project rate was 44100)
  3. The error occurs when trying to play the audio (it also happens when trying to record)

Thanks for your help. I’m doing this troubleshooting using the Mac Pro I mentioned above since that’s my goal. Since the error also occurred with the MacBook Pro I assume the same would happen there.
Screen Shot 2016-08-08 at 9.44.02 AM.png

Did the instructions give you any clue at all what the settings should be? Google? Once you get into wacky settings like that, it pays to get real info instead of hunt-n-peck.


I’m sorry but I really don’t know all that much about this device. My understanding is that it was simply purchased and then we plugged in the USB to the computer and it has worked great ever since. So, if the settings are “wacky settings”, I’m not aware why or how to change them. Perhaps you mean that the 32000Hz number within the Midi Settings is strange. If so, I have no idea how to change it. That field is not editable in Midi (even though it looks like an editable text box). The user manual (available here: says “Performance Speech processing and echo suppression at 32KHz sampling rate)” but that didn’t help me understand this problem any better.

Thanks again for your help. If you don’t know how to fix this particular problem, perhaps you could guide me in finding out who could help. Thanks for that.

I can think of one oddity that Audacity may not know how to handle. This is a full-duplex device, completely happy with pushing sound both directions on the USB cable at the “same time.” (Same time in quotes. USB can’t actually do that.) Even though the Mac can manage that, I’m betting Audacity can’t.

On a guess now, Audacity steps on the record data at the exact time the Duet reverses direction. Or worse, Audacity tries to record during the switch. Audacity would see the wrong device.

Audacity doesn’t like working with network drives for similar reasons. It doesn’t understand data collisions and delays.


Have you installed the “Phoenix Audio Setup Utility” referred to in the manual?

Did this ever work with Audacity? Can you try 2.1.3-alpha from the top of

What applications have you successfully used to record with it, for example GarageBand? Does it record its own microphone OK (your side of a call)?

Have you asked on their support channel ?


Gale, Thank you very much for your efforts to help. I have been able to successfully make recordings and also to playback using Quicktime when the Phnx MT202pcs was set as the Input and Output device. I downloaded Audacity 2.1.3 alpha Aug 9 and found that I was able to record with the Phnx MT202pcs set as the input. However, I could not playback with the Phnx MT202pcs set as the output – to listen to the recording I had to switch to other output such as internal or headphones. I also have no problem recording and playing back with Audacity using headphones/internal speakers.

So, with this newer version of Audacity the only problem appears to be with playback. I also noticed that Audacity did not pickup the headphones as an output device, although it did pick it up as a recording device (although it names it “Built in microphone” instead of “External Microphone”. This computer has no "built in microphone). The attached screenshot shows this.

Regarding the utility you mentioned – I can’t do that because it’s only for Windows and I’m working on a Mac.
2.1.3 a Aug 9.png

What was the playback problem with MT202pcs in 2.1.3-alpha? “Error opening” again?

Is the “Built-in output” in 2.1.3-alpha not your headphones when they are connected? Try Transport > Rescan Audio Devices in the Audacity menu bar if you just connected your headphones while Audacity was open.

Also can you post the saved file from Help > Audio Device Info… in 2.1.3-alpha (and also in 2.1.2 for comparison, if you still have 2.1.2).


Sorry for the delay – vacation time…

To answer your questions:

  1. yes, the error when trying to play back with the Phnx MT202pcs continues to be the same error: “Error opening sound device. Try changing the audio host, playback device and the project sample rate.”
  2. yes, I continue to use the “2.1.3-alpha-Aug 9 2016” version
  3. regarding effect of the microphone on the input and output audio, see the attached 3 screenshots. Specifically, note that the microphone does not show up in the output box at all, even if restarted, or even if Transport–>Rescan Audio devices is used

I’ve also attached the deviceinfo as requested
deviceinfo.txt (3.84 KB)
3 - audacity does not show microphone as the built in output no matter what.png
2 - after restarting audacity, however, the micophone shows up.png
1 - audacity doesn't show microphone as input when it is plugged in.png

Audacity does not see USB devices plugged in after Audacity is already running. Transport > Rescan Audio Devices or restart Audacity.

Obviously the built-in microphone will not appear as an output device in Audacity. If you want to use your headphones for playback, try selecting the Built-in output in Audacity.

I don’t know what else you can do to play to the Phnx in Audacity. You can try changing the project rate to 44100 Hz (although that would be a mismatch). You could try the dropdown menu in the audio track, set “Format” to 16-bit.

You could try Audacity > Preferences…, “Recording” tab and experiment with changing “Audio to buffer” up or down (that setting affects playback too).


I have tried your suggestions. I tried project rates of 44100 (the default that it goes back to) and 32000 (the value shown for Phnx MT202pcs in the Audio MIDI setup (that value cannot be edited there). I tried changing to 16bit

For the Preferences–>Recording–>Audio to buffer setting, I tried 10, 50, 100, 200, 500, and in each case after making a test recording, I also tried changing the Audio Track dropdown to Format–>16bit

Nothing allowed playback on the Phnx MT202pcs

I think I’m ready to surrender now, and just accept that I will need another playback device when using Audacity.

But thanks for trying.

2.1.3-alpha changed to use a later version of the PortAudio audio interface that we use for playback and recording. So it could be your device is not really compatible with PortAudio or susceptible to different versions of PortAudio.

If so you could try for example 2.0.3 and 2.0.4 from both of which use different versions of PortAudio from 2.1.2.

Have you tried rebooting the computer? Sometimes it helps with USB audio devices.


I noticed you have the “LogMeIn” VPN client. The Sphnx is a conferencing device. Maybe LogMeIn is stealing its audio output from Audacity?

Is there a setting in LogMeIn to disable audio? If so, have you tried disabling that?

I wondered about that too, but in the latest screenshot of output devices

LogMeIn is not shown. Also QuickTime can play to this Phnx device.

I would still try Cyrano’s suggestion, though.


I appreciate that you folks are not giving up on this as easily as I have, so I went to the effort to

  1. reboot the computer
  2. install Audacity 2.0.3
  3. testing the Phnx MT202pcs by recording a short portion of audio and then attempting playback on it
  4. doing the above test with either 44100 or 32000 project rates
  5. changing the sample format between 32 float to 16 pcm

Unfortunately, I still experience the same thing: recording works on the Phnx MT202pcs but playback does not.

Regarding the LogMeIn, I went through the steps to thoroughly uninstall that once I saw it was there recently. As I mentioned earlier, this is a bit of an older computer, but it’s still got a lot of life left, I think after all the upgrades: a 2009 Mac Pro (tower) upgraded with a 256 SSD, 12GB ram, lots of HDD space, and up-to-date software.

Thanks again

How did you uninstall logmein?

It seems stealing audio is a long standing issue with this program that still isn’t fixed in the latest version:

It’s possible the kernel extension that is “helping” LMI, could be left behind and it would provoke the kind of problems you’re having. Have a look here:

From which I distilled:

1- Disable Logmein auto update from
Options - Preferences - Advanced - Software Upgrades.
2- Delete the driver from
/Library/Application Support/Logmein/drivers.
Logmein copies this driver to the System folder on startup.
3- Delete the driver from the System/Library/Extensions

Restart your Mac.

Is this the recipe you followed?