Persistent error stopping Audacity from working[SOLVED]

Have recently tweaked my computer to work on 64 bit version of Windows home premium 7. I have used Audacity without issue on many different previous versions of Windows but now I get this message ‘’ Error while opening sound device. Please check the input device settings and project rate sample ‘’ . I have no idea what the ‘’ input device is ‘’ but the project rate is set at 96000. HELP

What are you doing? What is the show?
You can get that error if you pick a sample rate or bit depth that your computer hardware will never achieve.

Try setting Audacity Preferences to 44100, 16-bit, Stereo.

Edit > Preferences > Recording
Edit > Preferences > Quality

If that starts working, then you can experiment with other settings.


There is also a very detailed Frequently Asked Question that solves most cases of this error: .


I have tried all your suggestions and the error still persists. I have up dated the sound drivers, I have ensured that all devices are selected properly and are defaulted and have the same bit rate and project rate as the settings in Audacity ( started with 16 bit and 44100 hz ). No matter what bit rate or project sample I select Audacity still won’t open, I have uninstalled and installed Audacity several times but to no avail

We can’t help with “still doesn’t work”, you need to give specific details - we can’t see your computer.

So which sound drivers do you now have and where did you get them from?

So what device do you have selected in the Device Toolbar and which device in the Windows Sound Control Panel? What sample rate and how many channels?

One thing which is NOT suggested anywhere in that article is re-installing Audacity. That’s a waste of time as it won’t fix the problem.
Did you try rebooting the computer?

I am using Microsoft High definition audio device and I checked the driver was up to date with them.
In the Audacity toolbar audio host is set to MME , input is Line in 2 channel high def audio
In sound control panel in the recording tab default device is Line in 2 channel high def audio which is enabled , set at 16 bit 44100 Hz which matches the settings in Audacity
Yes I have re-booted and same error appears

If the audio drivers for the built-in sound device are made by Microsoft they are generic drivers that are not matched to your motherboard and its sound device.

You will need to go to the motherboard or computer manufacturer’s web site and obtain 64-bit audio drivers for Windows 7 that are intended for your motherboard or computer model. There is some help with this here:
Missing features - Audacity Support .

You can also try Windows DirectSound host in Audacity and Windows “Exclusive Mode”. To enable the latter, right-click over the speaker icon by the system clock, and choose “Recording Devices”. Right-click over the Line In, then choose “Properties”. Then click the “Advanced” tab and enable (tick) both Exclusive Mode boxes.

But this is unlikely to help unless you have proper drivers for the sound device.



You are a true genius, downloaded Realtek drivers for 64 bit Windows 7 from Asus and within seconds was recording on Audacity again

Thank you so much Mo