I purchased a new Peavey FX16, mostly because of the accessible recording features. I heard many people were using Audacity to find the device and record from it, but I can’t get it to find the device. I’m running vista home(32 bit).

I disabled my regular sound card(I had always used an M-Audio USB interface that works fine), and hooked up the peavey mixer. It shows up as “Peavey Mixer” in device manager. Then I opened Audacity, and no device shows up in the the preferences tab. What am I doing wrong?


Maybe nothing. What version of Audacity? What operating system?

It’s Vista Home(32-Bit). 3.2ghz2GB RAM350GB HD
I tried both the stable and beta versions of Audacity. Currently I’m running beta version(1.3.7)
I tried the other version first. With this version, it won’t even open when the mixer is plugged in.
It only works when I divert back to my regular sound card.

You need to go into the Vista Control Panel and enable the Peavey FX16 in the audio section.
See here:

Ok, also the memstick isn’t being seen. I’ve uninstalled the software on it, it just says (no memstick), I apologize but this is the first time i’ve had any issues streaming audio to my computer. If you know anything elae I can do to it let me know? Thanks a lot man.


Got it working. Thanks your post solved the problem :slight_smile:

How did you do it?? I have the same problem

Which problem? WIth posts this old, it is usually best to start a new thread. State what version of Audacity you are currently running. Describe what you are trying to do and the problems you are experiencing. What steps have you taken to try to resolve the problem?