PC volume balance gets reset


I installed 2.0.3 after previously using 2.0.1 and found it has the following problem:

Each time I open Audacity (be it per double-click, or by opening a track by right-clicking it and selecting “open with Audacity”), my PC volume balance (picture below) gets automatically set back to 100 on all channels:

Sorry for it being German, but I think you can see what I’m talking about.

I like to keep my left channel at 75 % because my left ear is better than my right ear - I need to reduce the volume in the left channel to get an even stereo image. (I have already done this in the above picture.) It’s very annoying to open that menu each time I open Audacity.

Till this bug is fixed, I’ll stick to using 2.0.1. (I don’t know if this problem exists for 2.0.2.)

Since it doesn’t seem that I can edit my initial post (?), I’ll tack it on here: I use Windows 7 64-bit and install Audacity from the .exe installers.

Thanks for the report.

I’m almost surprised 2.0.1 doesn’t have the problem. With the “older” type of L…R balance controls you used to get on Windows XP, this was much less often an issue.

Could you do some tests for us?

  • In 2.0.3, do you still have the problem if you choose “Windows DirectSound” host instead of “MME” in Audacity’s Device Toolbar?

  • Quit Audacity, download http://gaclrecords.org.uk/bugs/audacity_revert_r12160.zip, then extract “audacity_revert_r12160.exe” from the zip and put that EXE in your Audacity installation folder. If you run “audacity_revert_r12160.exe” from the Audacity installation folder instead of audacity.exe, do you still have the problem?


Yes. (However even if this solved the problem, it would not be an alternative, because recording with “Windows DirectSound” is glitchy; it gives me distortion on the stuff I record, while MME works just fine.)

Yes, that fixes it, very cool! Thanks =)

Is it identical with 2.0.3 except for the problem fix?

Windows DirectSound could be glitchy because you are selecting a project rate your card does not support, and/or you are not setting both “Exclusive Mode” boxes in Windows (I assume you are on Vista or 7 from your image). You can read http://wiki.audacityteam.org/wiki/Windows_7_OS#sample_rates that explains more, but recording latency may be lower on Vista and later with MME than with DirectSound, so MME may be preferable for that reason.

For most practical purposes, yes. The code change “r12160” that is reverted in that
EXE performs detection of Vista and later systems (and has some benefits in making Audacity interoperate on more Vista and greater machines with the system input and master output level sliders).

If you can, can you right-click in Explorer over the 2.0.3 (and/or 2.0.2) audacity.exe and over the “revert r12160.exe”, then choose Properties, then the “Compatibility” tab. Are any of those EXE’s running in Compatibility Mode, if so for what operating system?



Neither 2.0.3. nor the revert.exe are running in a compatibility mode.

Thanks for checking. If you run 2.0.3 in Compatibility Mode for XP, does it stop the balance reset?


Nope, it still resets the volume balance even in Compatibility mode (for XP, 2000 and NT). The revert.exe never resets the volume balance, regardless of Compatibility mode, in case that’s of interest, too.

Could you please try http://gaclrecords.org.uk/win-nightly/download.php?fname=./audacity-win-r12460-2.0.4-alpha-10-aug-13.zip ? That no longer uses the functions that were patched in r12160.

2.0.4 is currently expected to be released with that change, if we don’t have second thoughts.

While testing could you please try playing and recording at different sample rates, and try changing to WDM/KS host in Device Toolbar and see if that host plays correctly to your output devices.

Thanks for your help.