Part of playback sometimes silent!

Hey folks! I have a strange problem with Audacity. I have tried version 2.3.3 and 3.1.2.

I used to use Linux Mint 18, and everything was fine. I recently upgraded to Mint 20.3, which is where the problem started. I have the 5.4.0-91-generic kernel. Audacity 2.3.3 comes in the repos and I downloaded the 3.1.2 AppImage but the result is the same.

Problem: In the Audacity window, when I click “Play” to play back a track, sometimes the audio is silent for 1-2 seconds and only after that the audio starts. The blue playback indicator is moving during this silence, and the audio resumes at the correct location.

Example: let’s say the audio is a voice saying “Good morning”. If I select that part and play it, it might only say “morning”. It only happens sometimes, and if I replay it again then the full “Good morning” plays.

Things I have tried:

  1. Changing the latency to various values like 10,20,30,100, etc.
  2. Changing the latency compensation to different values
  3. Turning “Vari-speed play, micro-fades, always scrubbed unpinned” on and off. I also tried changing the “Seek time when playing”

Important: I can always tell when this is going to happen because when I click the play button, sometimes the interface seems to hang for half a second, like it’s a big laggy. When that happens, I get the silence in part of my playback.

Is there any hope for my system?

I thought I’d post a little update. I think the problem actually might not even be Audacity’s fault. Last night I noticed the phenomenon to a lesser extend with the Audacious music player so I am guessing it might be a weird audio problem in my new Linux system. Audacity shows this problem way more often for some reason but I’m going to explore this other avenue.