Parameters not getting passed in spectral edit Preview

Using 2.1.2 RC1 on Windows Vista Home Premium, 64 bit system. When I tried to use Spectral Edit Parametric, Preview gave me the message “Please select frequencies”. I had marked a nonzero width frequency band, but the effect apparently wasn’t receiving it. I’ve used this effect before in um, 2.1.0, I think, with no problems. I wondered whether having Single Band Parametric open had anything to do with it, so I closed that window. It made no difference. I then tried Spectral Edit Shelves just to see if the problem existed over multiple effects, and this time Preview gave the message Could not update effect “Spectral edit shelves” with: freq=“421.000000000000” q=“14.000000000000”. These were the parameters I’d used most recently in Notch Filter.

Back to Spectral Edit Parametric, I tried OK instead of Preview and it worked, properly! Tried Preview again, and again got “Please select frequencies”.
Spectral Edit Shelves also worked without an exception when OK was pushed, but I did not check the result, i.e. that it used the correct parameters.

Thanks, Dick. The Preview error has been fixed since 2.1.2 RC1. Try the 2.1.2 RC2 when it gets posted on FossHub.