Overdubbing suddenly doesn't work

Windows 10. Dell Latitude E6430. Behringer UMC204HD. Audacity 2.2.2

I was able to overdub until recently, maybe the past couple weeks. I haven’t changed any settings or done anything different. But now it isn’t working. I lay down the first track in mono or stereo with no problems. Either works fine. Then I want to overdub a second track while hearing the first track. Press record and a second track is created but it does not record. Vertical red line appears at the start, but doesn’t move and the first track cannot be heard. Press Stop and then a message appears:

“Latency Correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to start at zero. You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.”

Recording Device and Playback Device in Audacity both have the BEHRINGER UMC204HD selected. I have overdub selected in Preferences > Recording and Software Playthrough of input deselected. If I deselect overdub it does record but I can’t hear the first track. I am monitoring with headphones plugged into my Behringer interface. If I change playback device to the laptop speakers overdubbing does work.

I checked the sample rate for the UMC204HD in the sound devices control panel, its at 44100 Hz, which is same in Audacity Preferences > Quality as well as Project Rate. I’ve checked other threads about this same problem and generally tried the advice given. One thing I didn’t try is uninstalling the Behringer drivers and then trying to record. I did uninstall and reinstall them though. Also recently uninstalled and reinstalled Audacity.

That’s what happens when you scramble Overdubbing and Not overdubbing.

De-select Overdubbing > OK. Go back into the panel and select it again > OK.

Does that help?


Reinstalling Audacity doesn’t reset Audacity. Audacity keeps settings and preferences in a different place so you can upgrade without putting all those changes in again. In Windows, you have the option of clicking a reset button during the install.


There is one driver concern.

Drivers have to be written for Windows 10 and they have to say so. There is no “Windows Driver.” There is only a “Windows 10 Driver.”

There is some doubt whether you need to install Behringer drivers at all if you’re using them for simple jobs. Someone said they’re class compliant and I can’t swear to that, but I have several Behringer devices and I’ve never used any drivers Windows or Mac.


I solved the problem by uninstalling the Behringer UMC driver. Interestingly it currently doesn’t appear among the listed drivers available for download on the product web page


The one I have in my downloads is in a folder named UMC_Driver_v3.29.0_Win7to10


I’m having the same problem, I’ve adjusted the latency and checked the overdub box, still not working?