Overdubbing issues

My first attempt at overdubbing so I hope theres is simple fix to this problem. I am recording using the usb connection from a yamaha MG10XU mixing desk I import a backing track on to the recording track I can hear the playback of this through headphones attached to the yamaha. I set up an overdub track say vocals through one of the mixer channels I can hear the backing track and also my vocals however the backing track is also recording on to this second track when what I want of course is to hear the original backing track to cue the vocals but only record the isolated vocals to this track. Any ideals as to how I achieve this I Have checked Overdub in preferences Help please driving me nuts!!

Chances are good you’re not recording your mixer. You’re recording What-U-Hear or Stereo-Mix, the setting you need to record internet shows with Audacity. Those two job settings are different. Select the mixer for recording in the Device Toolbar.


You have correctly set Overdubbing in Audacity, but you shouldn’t have anything else selected in that panel.

When you get it all working, you should post back and let us use your mixer as certified for overdubbing. Many mixers won’t do this.