Overdubbing - Echo/Latency(?)--------

Audacity 2.1.3

.exe installer

Windows 7 Professional/Internet Explorer

I have been using Audacity since 2015 (Audacity 2.1.0) and have had 0 problems recording multiple tracks.
When I attempted to lay down some new tracks just 1 week ago, I incurred problems when attempting to
add tracks (overdub).

First, I couldn’t hear the rhythm track in the headphones so as to put down the vocals. I contacted Berklee Online tech support (I’m a student)
and they had me go to Edit, click preferences then click recording. Then they had me click BOTH boxes, i.e., Overdub: play all tracks…& Software Playthrough: Listen to input while recording…THE ISSUE: NOT IN SYNC!!! Also, severe echo.

I contacted Berklee again and they had me start playing with the latency factors - once again, no luck.
I contacted my Producer in Nashville and we tried everything he knew and subsequently upgraded to the 2.1.3 version - Same issue.

It has been suggested to download a different program but I’m under the gun to complete this project and cannot deal with learning a new program at this juncture. Besides, I am familiar with Audacity and feel there has to be a fix.

I am and have been using Logitech headphones and a Blue Snowball Ice microphone. Both have USB jacks.

Time is of the essence as I have to complete this project prior to our production session in 2 weeks. Can you HELP me?

Audacity > Edit > Preferences > Recording should never have both Overdub and Playthrough selected at the same time.

[X] Overdub should be enough to play the backing track into your headphones and record the new live performance. The only restriction with the system you have is not being able to hear your own live performance. That’s when you push one of the headphone muffs off your ear so you can hear yourself.

If you can’t hear the backing track, that’s a different problem. Can you hear anything? Can you play a YouTube clip and hear it?

Sometimes when Windows restarts, it scrambles USB sound connections. Right-click the Windows speaker and make sure Windows can see everything in the right place. Then see that Audacity’s Device Toolbar is set up right.


Which headphones exactly? Analog or USB?


and a Blue Snowball Ice microphone. Both have USB jacks.

Also, make sure you’ve selected the USB mic as you recording device.

If you record WASAPI Loopback, or Stereo Mix, etc., you’re recording what’s coming out of the soundcard, creating a loop/feedback (with delay/latency), and you’ll get echos (or feedback & oscillation).