Overdub with Scarlett 2i2

Hey all, I’ve been digging through the boards like crazy and can’t seem to find a solution that works!

I recently upgraded to a new laptop, and I can’t get overdubbing to work within Audacity. I’m using the same setup that I used on my old laptop, but for some reason I’m now getting the same error every time.

I am recording long-form voiceover, so overdub is key when I need to back up and correct a mistake–I need to be able to replay the few seconds of audio before the pickup so I can match flow, tone, etc. I’ve connected my Blue mic thru the Scarlett 2i2, and I’m monitoring directly from the device, no problem. I can record a single track, but when I stop and try to record a second track with overdub, I get an Error. Recording Device Not Found.

All of the settings (rate, depth, etc) are correct, matched with the specs of the 2i2, and the device is definitely capable of recording and playing back simultaneously because I’ve done it before. I’ve updated the drivers for the Scarlett AND my sound card. I even tried uninstalling Audacity and installing the older version that I was using on the old computer, and I still get the same error. My computer absolutely recognizes that the Scarlett is attached–system sounds are playing through the headphones, no problem.

I’m running Win 10 on a Lenovo Yoga 910 laptop.

Any insight here would be SUPER appreciated. I’m essentially screwed until I figure this out.


I think the hint is the failure half-way through overdubbing. Both the Record and Playback settings have to be correct and match. No fair having playback at 44100 and record at 48000, for example. Audacity, the drivers and Windows all have to match.

Another common problem is crossed settings from YouTube recording, for example. Windows has to “fold back” the playback side and jam it into the record side for Audacity to record on-line content. Overdubbing is two simple, very straight sound pathways, Record and Play. The two recording techniques are fundamentally incompatible with each other.


UPDATE: Installed the Creators Update that downloaded yesterday and now everything works! So apparently Windows was just screwing with me.