Overdub Troubleshooting

I have a Scarlett 8i6 audio interface and im running the latest version of audacity on a windows 8 asus laptop with an intel i3 and VIA HD Audio sound card.

I can record single tracks on audacity and have been doing so for the last week. Recently i’ve wanted to try to do some overdubbing.

when i hit the record button for a second track this error message popped up.

‘Error opening sound device please check the input device and the sample rate’

I googled that and came to the audacity’s wiki. On the wiki it said to go to the transport menu and disable overdub and software playthrough.

i did both those things and i was able to record a second track but i can’t hear the rhythm on the first track i recorded.

So i googled the manual and came to this section on not being able to hear playblack and on that page it says to turn on the software playthrough. I turned on the software playthrough and i ended up ‘Error opening sound device please check the input device and the sample rate’ message again. I have also tried adjusting the sample to lower rates and thats been completely ineffective. Feel like im going in circles. I hope you guys have some insight on this. Thanks.


“Overdub” should be enabled (On).
“Software Playthrough” should be disabled (Off).

What options are available and which do you have selected in the Device Toolbar .

  1. MME/windowsdirectsound 2. Microsoft Sound Mapper - output/(line out) Scarlett 8i6 usb/Speakers(VIA High Definition Audio) 3. Microsoft Sound Mapper - output/(line in) Scarlett 8i6 usb/Speakers(VIA High Definition Audio) 4. Mono/Stereo

That looks OK to me on the Audacity side, though you could try setting “host” to “DirectSound”.
Beyond that I think you need to be looking to the Windows Sound System settings. Sorry I’m no expert on the Windows Sound System (I generally use Linux), but a good place to start is the Windows Sound Control Panel.
There is also a post here with a solution to what seems to be a very similar problem: https://forum.audacityteam.org/t/persistent-error-stopping-audacity-from-working-solved/29200/7

I switched it to windows direct sound and clicked overdub on. Audacity has two errors “unanticipated host error” followed by the ‘Error opening sound device please check the input device and the sample rate.’ I’m going to read the topic you sent me and see if there’s anything in it.

Audacity has to achieve two different connections to Windows Services when you do overdubbing. It has to record from your “Microphone” and it has to play your existing tracks to your speakers/headphones. If either of those is fuzzy or messed up, Audacity will throw the Unable to connect… error.

And just to fully connect the dots, you are singing into a microphone connected to the Mic-In of the sound card, right? We have been burned too many times by people who naturally assume “recording on their computer” means capturing YouTube sound. What else could you want?


I know it’s a standing joke, but if you start getting serious system errors, you should restart the machine from power off. Make it start over. If you continue to get these errors, inspect the drivers and soundcard software.


Are you using the Focusrite driver from here http://uk.focusrite.com/usb-audio-interfaces/scarlett-8i6/downloads ?

Also see http://wiki.audacityteam.org/wiki/Windows_7_OS#sample_rates . Assuming the bold text in your device list means that you are using Scarlett as input and output, tick both “Exclusive Mode” boxes in Windows Sound, choose Windows DirectSound in Audacity, then choose a sample rate supported by Scarlett and choose that same rate everywhere: each Audacity track, Audacity project rate and in any of the Scarlett software programs that you may be using.

Also if you are actually recording a mono track, tell Audacity to record mono rather than stereo.