overdub recording

i did overdub drum track with my guitar, the result is the drum’s sound also included on my guitar wave… when i played back the guitar track that ive recorded, the drum sound also could heard from the track…i dont knoww how to setup

What’s the numbered version of Audacity?

Do you like recording on-line content like YouTube sound?

Audacity > Edit > Preferences > Recording: [X] Overdub. That should be the only thing selected.

Audacity Device Toolbar > Microphone Symbol (recording). That should be your single recording device such as USB input or Built-In Microphone. It should not be the setting you use for recording YouTube videos.

Use headphones. You should never have a live microphone and speakers in the same room.



It should not be “Microsoft Sound Mapper” either. You have to explicitly set the input device that you are actually recording from.