Overdub Problems

I am in the process of recording an audio cd of my girlfriend’s favorite music to be used in an elaborate proposal for either Christmas (not looking good) or Valentine’s Day. Being a fulltime student with 2 jobs I’m just now really getting going on the project. I recorded the first track of the first song with no problem. I played acoustic guitar, harmonica, and sang using a USB Blue microphone and the playback sounds great. I wanted to overdub banjo and harmony vocals on the second track and call it done. I plug in my headphones so I can listen to the first track without it interfering with the new track but it always stops recording halfway through. Then the sound is way out of sync. Is this a computer problem or am I doing something wrong in the preferences?

Josh

At first flush, I’d say yes, your machine isn’t up to complex overdubbing. An overdubbing machine has to maintain perfect mixdown and playback of multiple tracks and record a new track – also perfectly and all in synchronized real time. That’s not easy.

You can take this upside down. If you wanted a computer speed and agility test, Overdubbing would be the way to go.

What processes and tasks can you stop running while you record? If your computer is trying to do a Photoshop Blur or check email during the recording, that’s probably not going to work.

I guess the desperation method might be to use a simple mono click track as a base for rhythm and playing into your headphones instead of trying to manage all existing tracks in real time.

I’m assuming you didn’t run out of drive space… I have to ask that. Are all your drives local? Audacity will not overdub into USB or network drives.

Koz

Yes all my drives are local. I’m using Ubuntu 13.10 and Audacity is the only program I have open while I’m doing it. This is a new laptop though it’s not the most top of the line. I might have to do a scaled back version of the proposal cd and only do the 1 man band approach.

If there is a selected (highlighted) region, then recording will stop at the end of that region.
To ensure that there is no selected region, press the Home button before you start recording.

What options are available and which options are selected in the device toolbar?

No there isn’t anything highlighted. It stops at different points every time. One time it got almost to the end. Sometimes it doesn’t even get through a chorus. On devices it shows the following:

Interface: Host: ALSA (that’s the only option)
Using: Port Audio V19 Devel

Playback: Device: Default (there are several options including surround, front, HDA, etc.

Recording: Device: Blue Snowball: USB Audio (there are several options here but the Blue Snowball is my microphone)
Channels: 1 (mono) I recorded the first track in stereo and thought maybe using mono would help with the issue I was having.

What are the other options?

The other options under playback are:

HDA Intel PCH: ALC270 Analog(hw:0,0)
HDA Intel PCH: HDMI 0 (hw:0,3)
sysdefault
front
surround40
surround51
surround71
hdmi
pulse
dmix
default

Try selecting HDA Intel PCH: ALC270 Analog(hw:0,0)

Note that this will bypass PulseAudio which means that Audacity will need exclusive access to the sound card - no other applications using audio playback at the same time.
If you have had other audio applications playing, you may need to log out and back in again so that the sound card is available.

This may be exactly what you were saying with needing exclusive access to the sound card but when I have it set on that setting I can’t hear it in my headphones. If I unplug the headphones I can hear it through the computer speakers but obviously you can’t record a second track with the first track playing through the computer. Did I do something wrong? Is there another option? Or am I just cooked?

Josh

Where are your headphones plugged in?

They are plugged into the headphone jack on the side of the laptop.

On further testing the headphone problem is not with audacity. All of a sudden my headphone jack doesn’t work at all. Headphones work fine on my keyboard so I know it’s a laptop issue. That’s just great. I guess this project will definitely have to be single tracked now.

Josh