Overdub problem PLEASE HELP.

Have a seriously annoying issue, using audacity on windows 7.

When I tick overdub the track is meant to play while I record a new one, (Which it was doing fine yesterday) but today for no reason, what is happening is that the new track is also RECORDING THE TRACK I AM PLAYING?? Whatever I do i cannot record separate tracks now??

I use line in to add instruments such as guitar etc, but as I play the track, I can hear it, but it records it as well. I need it to play but not be recorded.

If I turn off overdub, obviously I cannot hear what I am playing while recording.

I do not need software play through, as doing that requires me to turn of ‘Stereo Mix’ which means I cannot record anything, including the line in??

I hate windows 7…never had these prtoblems on XP and I fear that this issue is to do with the VIA HD & win 7 overcomplicated sound settings.

Any ideas?

cheers. cole.

Overdub should be the only thing you have selected in that panel. You should be recording from your sound device only and not Stereo Mix or anything else. Audacity should be set to play to your speaker, headphone or sound device depending on where it needs to go.

Other combinations will give you echoes, double recording or other problems.

You tried to record YouTube sound between yesterday and today, right? That setting is what’s giving the double recording.



thx for reply.

ok let me be a bit more clearer as i have not recorded from youtube or anything like that.

also I am not HEARING double tracks as it records.

Overdub is the only thing ticked on that panel.

Stereo mix is on via windows 7 mixer, (Turning it off prevents any recording for me in audacity?)

So firstly I record the drums (from program hydrogen) on one track.

I then want to add a guitar on a SEPARATE TRACK from (Line In), so I press record - starts 2nd track - and today for some reason it records not only the guitar, but also the drum track into this SECOND track?? It does not just record the guitar as a separate, but both together.

It did not do this yesterday, when I first tried recording.

Turning of ‘Stereo Mix’ prevents any recording, even of the Line In??? but I can still hear the drum track and the line in guitar, but it does not record when Stereo Mix is disabled?

Bottom line is - I want to record drums, guitar, bass + fx all on SEPARATE tracks, but obviously i need to listen to the FIRST drum track while I record the SECOND, but as I record the SECOND it also records the FIRST track while i’m listening to it, it should not be doing this.

Hope this is a little more clearer. It does not appear to be audacity that’s the problem here, its something to do with the VIA HD windows mixer settings (particularly the line in / stereo mix) but I need to have audacity set up correctly so I can troubleshoot the stupid windows 7 sound configs.

cheers for reply.

Stereo Mix is the system that contains Everything Playing On The Computer. So when you overdub with Stereo Mix on, Audacity will make the second track, the overdubbed one, with Everything. That’s why you get the original track plus the new one. If you kept doing that, the new overdub tracks would get louder and louder and eventually overload and die.

So Stereo Mix is not the answer. You have to find a way to record directly from your microphone, however you get it into your computer.

You may be stuck somewhere in here.


Scroll down to (3) Selecting Your Recording Device. If Stereo Mix can find it, then you should be able to show Audacity how to find it.

I’m not a Windows elf and this is a heavy Windows problem.

This is the overdubbing tutorial:


In each one of those instructions, there is a step where you make a simple Audacity recording without overdubbing. I’m guessing you never got past that step. You can’t do overdubbing without it.


Selecting devices in Audacity.


And yes, I know exactly what you want. Rhythm or guide track on 1, vocal on track 2, guitar on track 3, bass on track 4, etc.

I think part of this is a monitoring problem. You can set Audacity into a monitoring or diagnostics mode. Right-click inside the red recording meters > Start Monitoring. You can test your sound pathway that way. Audacity is now armed and ready to record and the meters are active. It just didn’t “roll tape” yet. So if you play the guitar and it shows up on the meters, you will get a recording in Audacity whether or not you can hear it.

Recording and Listening are two different processes, and you can have one without the other.

I know you need listening for overdubbing, but we also need to find out where the problem is. You think it’s a recording problem, and it may not be.


Totally expected if you did not change the Audacity recording device from stereo mix to Line-in. You can use Device Toolbar to change the Audacity recording device.

If you don’t see the Line-in, show disabled devices in Windows Sound then enable the Line-In when it appears. See Missing features - Audacity Support.


thanks gale & koz for all your replies, i will work my way through all the suggestions (Although i have already browsed and followed a lot of the audacity wiki pages but to no avail).

I understand that the Stereo Mix is everything that’s plays on the PC. But I need the ‘Line In’ to be recorded separate, which is strange because when I set Line In to default and restart Audacity and record there is nothing? and it still records the DRUM track into the second track, without no input from Line In, even though I can hear the line in through my headphones, so i need to delve further and try to make sure Audacity is set up to listen to the Line In.

I have fiddled with the Monitoring bars and prefs already but that did not seem to change anything, though I will go through it all again.

will get back to you all with an update.


But I need the ‘Line In’ to be recorded separate, which is strange because when I set Line In to default and restart Audacity and record there is nothing? and it still records the DRUM track into the second track, without no input from Line In, even though I can hear the line in through my headphones, so i need to delve further and try to make sure Audacity is set up to listen to the Line In.

I need to read through that again, slowly.

Did you select Audacity > Edit > Preferences > Recording > [X] Overdubbing and nothing else on that panel? That’s the setting that manages the special recording, playback and monitoring.

You got the drum…


I think I violated a forum rule.

We need you to describe in detail what you have connected to what. How are you playing the live music you’re making for the overdub tracks? Where are your headphones plugged in? I know you got the original basic or rhythm track (drums?) from another program and that’s playing on Audacity track 1. Fill in the rest.

I need to be able to go to the store and build your system when you get done describing it.


You need to tell Audacity which input device to use. The easiest way to do this is using Device Toolbar. Here it is inside a red border:

If you set Windows default recording device to Line-In, that does not change the Audacity recording device, unless you choose the “mapped” recording device in Audacity - that is, “Microsoft Sound Mapper - Input” (assuming you have MME host in Device Toolbar) or “Primary Sound Capture Driver” (if you have Windows DirectSound host in Device Toolbar). The “mapped” recording device is whatever the current Windows default recording device is.

So if you have stereo mix chosen in Device Toolbar then change the Windows default recording device to Line-In, Audacity will continue to record from stereo mix until you change it to record from Line-In or from the mapped recording device.

The most convenient way to change recording devices therefore is to change them in Audacity. You “should” be able to leave the Windows default recording device at stereo mix and change Audacity to record from Line-In.