Overdub Issue

I’m using a UM 2 interface with a condenser mic on my laptop (Windows Vista) just to do a simple vocal overdub on a backing track. Everything works fine and in sync for about 45 secs and then breaks up distorting badly and I’ve tried different tracks with the same result. This is all new for me so any help/advice would be greatly appreciated… many thanks!

You may be up against computer horsepower.

In order to overdub, the computer has to play the backing track absolutely, perfectly correctly into your headphones and at the exact same time, record the microphone absolutely, perfectly correctly. No options.

It’s remotely possible the UM2 or microphone is broken, but I sure doubt it. Much more likely the computer doesn’t have enough high-quality, fast drive space to do the work, or the computer is too busy doing other things…or both.

How big are the drives, how are they connected, how full are they and does Vista have a defragmentation tool?


Thanks so much for your response but I have no idea what any of what you are saying means nor how to find/go about doing the things you mentioned since I am a COMPLETE novice…I need Audacity For Dummies!

Try rebooting your computer, and then make a test recording (without running any other programs). What happens?

Hi Steve…tried a reboot with the same result: 30 secs into doing a vocal overdub the backing track starts to break up and distort…hopefully there’s a simple solution!

Please post a short audio sample to illustrate the problem, in WAV format. The sample only needs to be 4 or 5 seconds duration. See here how to post an audio sample: https://forum.audacityteam.org/t/how-to-post-an-audio-sample/29851/1
I think I can guess what the problem is, but an audio sample would show straight away if it is what I think.

Is your computer a laptop or a full size computer?
If it’s full size and you have the UM2 plugged into a USB socket on the front of the computer, try plugging it into the back of the computer.
If it’s a laptop and it has more than one USB socket. try the other sockets.
Also, check that the USB lead is securely connected to the UM2.

Hi again Steve and yes it’s a laptop. I tried switching USB ports with little success. Strangely, when I try to record the distortion it comes out clean (!) so at this point I’ m completely lost and even your best guess would be appreciated… thanks!