Out of memory when working with many tracks.

Hi. I ran into a problem when trying to edit many tracks simultaneously in audacity 2.4.2. I have 498 tracks averaging about 2 seconds each (14min total). Quality is 16-bit 44kHz stereo wave files. The files only take up 192 MB on disk, but in audacity, it takes up 1.4 GB ram. Why would it do this? Still, I’m only at about 47% ram usage so it shouldn’t be a problem but it is.

Is there a way to make audacity not load everything into memory? I only need one or two tracks as a reference when I’m mixing. I can still add effects to all the tracks without a problem, I just can’t playback anything which makes mixing a bit tricky.

Or maybe there’s a better way? Macros maybe? Any ideas?

Tell us more about what you’re doing. Why do you have 498 tracks in the project?

Audacity doesn’t use plain ordinary file formats. It uses 32-floating at 44100, assuming you used 44100 sampling rate. This is to avoid accidental overload and clipping problems. Internally, Audacity doesn’t clip.

Audacity gets some UNDO by periodically saving fresh copies of The Whole Show.

So it might pay to break up the show into smaller, less intense chunks and do it that way.


It’s text-to-speech clips for a mod that I’m working on. I want to add effects to every track and then save every track to a separate wave file. That’s why I cant have it all in one track. That would kinda defeat the purpose.

No, but you might do it in 25 or 50 track chunks instead of all at once.


The same effects with the same settings to every track?


Better to use a Macro to batch process the files.
See here: https://manual.audacityteam.org/man/macros.html
(Don’t forget to include an “Export as …” command at the end of the macro).

Give a shout if you get stuck :wink: