Opening target file for writing

I just installed Audacity, recorded a test, and want to save it as an MP3 file. I downloaded the Lame Library v3.98.2 Audacity on OSX.dmg file, opened it in Finder and installed the LAME binary “libmp3lame.dylib” in /usr/local/lib/audacity. Audacity should detect LAME automatically when I export as MP3. But when I try to export, I get a message “unable to open target file for writing”
This is pretty much the limit of my technical ability. Can anyone help me save a file as an MP3?!!!

Take the dates out of the filename. Never put punctuation marks of any kind inside a filename. It drives the Mac nuts. Upper and lower case letters, numbers, dash and underscore are the only unconditionally safe characters. Today is not 5/22/12. It’s 20120522. Use the ISO version of the date.

This is not an MP3 error.

That better?


Thanks but no, this doesn’t apply. Still need help!

It doesn’t. As you perfectly well know, the only illegal character on Mac is colon (:). As you will also know Audacity 2.0.0 (not Mac) still has bugs that it does not accept backslash () when saving a project, or forward slash (/) when exporting multiple. These restrictions can be found in the Release Notes .

That is good advice if you are sending the file to someone else who may be on another operating system, or over the internet. And for the above Audacity bugs if you are specific what the problem is.

See this Frequently Asked Question for operating system restrictions: .


I think it “could” be a permissions error on /usr/local/lib/audacity, but unlikely unless you are on Lion. Log in as admin then In Finder, try Go > Go to Folder, type /usr/local/lib/audacity, then move “libmp3lame.dylib” to somewhere in your own user space. Then go Audacity > Preferences: Libraries and use the Locate… button for LAME to select and open “libmp3lame.dylib” in its new location.

Or get the zip of LAME ( ) then extract the dylib file anywhere in your user space then locate it in Audacity’s Libraries Preferences.

If that does not help, try FIle > Open Metadata Editor, then press “Clear” then “OK”.

If that still does not help, are you using File > Export or File > Export Multiple? What directory are you saving the MP3 file to exactly?