Opening Audio File in Audacity via Firefox

Hi Audacity Team,

Firstly, thanks for your product. As an IT professional, I have used countless software over the years (paid and free) but have always found your product to be one of easiest, simplest and most effective pieces of software to date. So please, keep up the great work.

Now while I have not experienced an issue, one of our clients appears to be having some trouble and I’m crossing my fingers this is something that can be resolved with your expertise.

Client’s Environment:
Windows 7 64-bit / Audacity 2.3.X / Limited-technical knowledge

Client is unable to open MP3 files in Audacity via Firefox due to “… could not be found” dialogue.

Audacity is unable to open any parsed file from Firefox containing spaces. Audacity appears to be treating characters between spaces as individual files rather than one single file.

Now I have found one thread in particular which discusses this issue but more on Windows behaviour, particularly default file associations and shell commands. However it does highlight the requirement of encapsulating the variable (or passing filename) in quotations as to form a string.

It’s this particular reference that has caught my attention. I have reviewed various registry keys in relation to “audacity.exe” but all include the correct path:

"C:\Program Files (x86)\Audacity\audacity.exe" "%1"

This subsequently averted my attention to Firefox and it’s handler of applications and MIME types. This led me down all sorts of paths, including Windows shell. Now I’ve dabbled in programming over the years and regard myself fairly experienced with computing in general but this is a red pill I’m just not ready to swallow yet…

Now I know there may be alternatives to this dilemma such as setting the default association for MP3 files to Audacity or simply using “Open with” when required via File Explorer, however these solutions are not ones I can bring to our client, unfortunately…

I’m hoping someone can point me in the right direction to resolve this. Perhaps someone with in-depth knowledge of Audacity and integration into Windows shell. Even a manual registry fix if at all possible, as long as the client can use Firefox, click a MP3 file and choose to “Open with” Audacity in the dialogue Window and not be presented with the attached screenshot due to spaces in the filename.

Your time and guidance is most appreciated.

Thank you


What precisely do you mean by “opening MP3 files in Audacity via Firefox”?

Thanks for your reply Steve.

User clicks a hyperlink containing a URL to a MP3 file and is then presented with a dialogue window to open with a specific program. In this case, it’s Audacity.

So rather than downloading the file automatically to “Downloads” or asking where to save the file, it’s pipes the MP3 directly into Audacity.

I have replicated this issue on my machine running Win 10 Pro and latest vers of Audacity.

I also tried using VLC Media Player to see if Firefox was a potential cause, but the file opened without error.

Strictly speaking, it shouldn’t be, though we don’t dictate what users do/don’t do on their computers.
The “native” format for Audacity is the “Audacity Project”, comprising of a “project file” (file extension “.aup”) and a “data folder” (named with “_data” at the end). On first run, Audacity offers to associate “.aup” files with Audacity. Normally you would associate audio file formats with an audio player, not Audacity, though it is “possible” to associate any type of file with Audacity, and Audacity will attempt to import it.

It’s actually a bit more complex than that. If you associate MP3 files with Audacity, then “opening” the MP3 with Audacity launches a new Audacity project window, and then attempts to import the MP3 into the project. This is not a “design feature” of Audacity but rather just something that some users decide to do. I would not recommend doing so, and there’s no guarantee that it will work. When you tell Audacity to import a file, that file should exist. When trying to import the file across a slow network (such as an Internet link), the file may not have completed downloading before Audacity tries to read the data, and that could cause undefined problems.

In the case of VLC (or any other media player), the player is actually “opening” the file. This is the simple case that you describe as “piping the data directly into the application”, but is not what happens in Audacity.

My recommendation would be:
Always save the file to disk, then Launch Audacity and import the (fully downloaded) file.

Thanks for your reply and recommendation Steve. I’ll pass it along to the client.

I’m still curious though, why is Audacity unable to open a filename with spaces if opened with Firefox? Filenames without spaces open perfectly.

Yes that’s curious. I rarely use Windows, but my guess is that the file name that Audacity receives is not quoted, so it looks to Audacity to be a list of files rather than just one.

Hello_World.wav - no spaces, thus one file
“Hello World.wav” - quoted, thus one file.
Hello World.wav - not quoted, thus seen as “Hello” and “World.wav”.

Hmm, that’s what I suspect too. Perhaps my focus should now be on Firefox since it’s evident how Audacity handles filenames.

Thanks again for all your help Steve.

I’ll be sure to return here if the kind people at Mozilla and/or community can resolve this quandary.


It may be worth checking that the “spaces in the file name” isn’t a red herring. Try uploading an audio file to a web page with two copies of the same file - one with a single word name and the other with spaces in the name (but ensuring that it is the same, identical file in all other respects). Are you then able to reproduce the issue?

Same result. I even replaced the filename spaces with %20 (ASCII encoding) and tried opening it with Audacity from File Explorer to determine if that was causing any issues. Worked perfectly.

So at this point, it’s safe to say Firefox is not encapsulating the filename path variable with quotations such as the “Open with” shell command does with File Explorer.