Only Right Side Output iD14?

OS: Linux Mint XFCE
Audacity: 2.2.1 - distribution release

I’m using the Audient iD14 USB interface with Audacity. It records beautifully, but when I’m recording in mono or stereo I can only hear the output on the right side of my headphones.

Alsamixer shows both sides of the output at 100, as does Pulse.

I don’t have this problem with anything else on my computer.

Any ideas, suggestions?

and a microphone of some sort? 2 microphones? A Sure SM57 in the left channel and a Tachamine guitar with active pick-up in the right channel?
Too much detail is better than not enough - currently you have not given enough detail.

Hi Steve,

I’m using:

Audient iD14
Audio Technica plugged into mic port 1

Happy to provide more detail if needed, let me know.

As with many other external audio interfaces, the iD14 has two independent input channels. Channel 1 is the “left” and channel 2 is the"right". While monitoring, channel 1 is routed through to the left side of the headphones, and channel 2 to the right. This can sound a bit weird if you are only using one microphone, but it’s not a problem for the recording. If you record a microphone plugged into channel 1 as a mono track (set Audacity to “1 channel (mono)” in the device toolbar), then on playback the sound will be in both left and right headphones.

It may be possible to monitor the live sound after it has passed through the computer so that you hear channel 1 in both sides of the headphones, but it takes time for the sound to pass through the computer, so there is a delay between sound going in and sound coming out of the headphones. This delay is called “latency”, and in many cases it is worse than just using one side of the headphones with no delay.

Gotcha.

It’s already set to Mono. Since that affects nothing, how do I monitor the live sound so I can hear channel 1 in both sides of the headphones? I understand that there’s a latency issue, but I’d like to try anyway.

The best way is to use “Jack” as your Linux audio system.
Setting up Jack can be a bit difficult, though if you are lucky it can be as simple as installing QjackCtl and allowing that to pull in the necessary dependencies. (Some distributions, such as UbuntuStudio, install Jack by default).

The advantage of using Jack is that it has relatively low latency (minimal delay between sound going in and coming back out again), and that routing signals is very easy using the “Connect” panel in QjackCtl.

Here is the Connect panel in QJackCtl with Audacity recording in mono from the left input of a 2 channel USB interface. Notice that I have connected the left input channel to both left and right “system” outputs. (“PortAudio” is Audacity’s input which appears when Audacity starts recording).

QjackCtl.png

Thanks. I was able to install QjackCtl without any troubles, but nothing shows up under connect. I tried it while Audacity was recording, and while it wasn’t.

If there’s literally “nothing” under connect, then Jack isn’t running.

You need to:

  1. Open QjackCtl

  2. Open"Setup" and configure Jack for your iD14

  3. Start Jack running (steps 2 and 3 are the tricky part. Google is your friend)
    When you see that Jack is running without errors …

  4. Launch Audacity (MUST be after Jack has started)

  5. Select “Jack Audio System” as the “host” in the device toolbar.

  6. Select “System” for recording and playback in the device toolbar.

  7. Click on the recording meter to activate the recording meter.

  8. Now open “Connect” and you should see that Audacity is connected to “System”.

I found this on-line, which may help: http://adrjork.altervista.org/linuxtricks/JackTutorial_64studio.pdf

I appreciate the detailed instructions - I’ll let you know how it goes.