Nyquist returned the value with the default delay plugin

Hello everyone,

I’m using Audacity 3.0.2 on Linux Mint 20 Cinnamon OS. First I have installed Audacity through the Software Manager and updated it today through the Update Manager. It seems that the default Delay plugin does not work for some reason when applied to the track it says “Nyquist returned the value” followed by a super long number. The screenshot is in the attachments. Please help me, delay is a crucial moment of the mixing process for my project.
Screenshot from 2021-07-17 18-23-46.png

Did this occur after importing an old style “AUP” project?

If so, try this:

  1. “View menu > Toolbars > Spectral Selection Toolbar” (enable it)
  2. In the “Spectral Selection Toolbar” that appears at the bottom of the main Audacity window, values into both fields (it doesn’t matter what values, any valid values will do).
  3. (Optional) turn off the Spectral Selection Toolbar to return to your usual toolbar layout.

Now try using the Delay plug-in.

Yes it did occur after importing an old .aup and saving it as .aup3 file.

Thank you for the suggestion but enabling the Spectral Selection Toolbar changes nothing. Nyquist returns the value the same way.

No, actually it worked! Thanks, I did not realize at first that I needed to enter values into a toolbar. Thank you so much for your help!

Thanks for the update.

The problem was caused by a minor bug in Audacity: When an AUP project is imported and the project does not define a spectral selection, the spectral selection settings are left in an undefined state, which then causes a problem in Nyquist. The bug has been fixed for Audacity 3.0.3 (the next Audacity release version). Until Audacity 3.0.3 becomes available, just use the workaround of manually adding values for the spectral selection.