Nyquist plugins not loading after [SOLVED]

  • Audacity version: 2.1.2
  • Operating system: macOS 10.12.1
  • Details: I updated my Audacity app to v.2.1.2 today via the .dmg installer. After restarting my computer, I imported an audio file & attempted to use one of the included Nyquist plugins (vocal reduction & isolation), which was working a few days ago in Audacity v.2.1.1; but an error message popped up saying “Error: dlopen(.bundle, 2): image not found”. After quitting & re-opening audacity, I tried opening multiple Nyquist plugins & received the same error message. Below is the log I obtained after the restart:

09:44:50: Audacity 2.1.2
09:44:50: Warning: Critical Nyquist files could not be found. Nyquist effects will not work.
09:44:51: Trying to load FFmpeg libraries…
09:44:51: Trying to load FFmpeg libraries from default path, ‘/Library/Application Support/audacity/libs/libavformat.55.dylib’.
09:44:51: Checking for monolithic avformat from ‘/Library/Application Support/audacity/libs/libavformat.55.dylib’.
09:44:51: avformat not monolithic
09:44:51: Loading avutil from ‘/Library/Application Support/audacity/libs/./libavutil.52.dylib’.
09:44:51: Loading avcodec from ‘/Library/Application Support/audacity/libs/./libavcodec.55.dylib’.
09:44:51: Loading avformat from ‘/Library/Application Support/audacity/libs/libavformat.55.dylib’.
09:44:51: Actual avutil path /Library/Application Support/audacity/libs/./libavutil.52.dylib
09:44:51: Actual avcodec path /Library/Application Support/audacity/libs/./libavcodec.55.dylib
09:44:51: Actual avformat path /Library/Application Support/audacity/libs/libavformat.55.dylib
09:44:51: Importing symbols…
09:44:51: All symbols loaded successfully. Initializing the library.
09:44:51: Retrieving FFmpeg library version numbers:
09:44:51: AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
09:44:51: AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
09:44:51: AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
09:44:51: FFmpeg libraries loaded successfully.
09:45:12: Error: dlopen(.bundle, 2): image not found

I tried re-installing audacity, which did not hep. Also, I opened up the plugin manager & noticed that even though all the Nyquist plugins were visible in the Effects menu, they were all showing up as Disabled in the plugin manager window. I tried selecting them all, clicking “Enable” followed by “Ok.” However, after doing this all the Nyquist plugins were now gone from the Effects menu! I opened up the plugin manger & they were all listed as Disabled again? Every time I tried to enable any/all of them they automatically reverted to disabled as soon as I closed the plugin manger window.

Not sure if this is a bug or something wrong with my specific install, but any/all help/tips would be greatly appreciated!!
audacity_dbgrpt-2657-20161210T100045.zip (24.2 KB)

Make sure you installed Audacity according to https://forum.audacityteam.org/t/installation-do-not-run-audacity-from-the-dmg/31711/1

If the problem persists, please see https://forum.audacityteam.org/t/nyquist-effects-missing/43925/9


Thanks for the links! I definitely installed it correctly according to the info in the first link & I had already tried restarting, so I knew that wasn’t going to help either. I tried opening the shell application within Audacity’s packaged contents & was able to load the Nyquist plugins successfully, but even after closing Audacity & restarting my computer they still wouldn’t load if I opened the app normally from the applications folder.
Finally after resetting the xattribute via terminal & restarting my computer again, it worked!

Thanks again for posting those links!