Nyquist Plug-In problem

I just got a new laptop with Windows 10 and installed Audacity. When I went to Effects, everything was greyed out. I went and checked the Plug-Ins Folder and found all of the Nyquist plugins were there already. I reinstalled them as well as the LADSPA Plugins and… The LADSPA Plug-Ins show up, but the Nyquist ones don’t. They’re all greyed out. I tried restarting the computer and disabling and reenabling everything (it listed them as Enabled in the Add/Remove Plugins prompt), but nothing worked. I’m gonna break out my old laptop to record today since I have to get stuff done, but anyone have any ideas? I haven’t gotten any errors from Audacity, but I also haven’t used it yet on my W10 computer.

Any help would be greatly appreciated!

Most functions, including effects, are greyed out during play, record and pause. To enable editing and applying effects, playback must be stopped (click the “Stop” button).

I wasn’t playing or recording anything. I was setting it up… I-- Realize that I had no active tracks to apply the effects. I just confirmed this on my other computer. If I don’t have a track to apply them on, the built in functions are greyed out.

On the Windows 10 Computer though, all of the additional plugins show up as black. Phaser and WahWah do too for some reason. On Audacity 2.0.5 on my Windows 7 laptop, all of the plugins are greyed out when there are no active tracks. Weird.

Thanks for your help!

Just to clarify, if there are tracks but you don’t select any audio, and assuming you are not playing or recording, then by default effects are available but the entire project’s audio will be selected for you.

If you have turned off “Select all audio in project, if none selected” in Tracks Preferences then if you don’t select any audio in the tracks, the effects will be greyed out, except for Real-time preview effects. Phaser and Wahwah and VST or LADSPA effects are real-time preview effects.

If you have no tracks, then real-time preview effects can still be opened, but can’t of course be used.