nyquist error on vocoder [SOLVED]

I wanted to use the vocoder on my sound by changing the right channel of my stereo track to the generated noise (white). When i used the default settings of the vocoder, it showed “Nyquist returned the value: 2205.000000”, and when I used debug it showed “error: unbound function - SET-CONTROL-SRATE” under nyquist output. How can I solve this problem? Thanks

Which version of Audacity (look in “Help > About Audacity”).
Are you referring to the Vocoder effect that is shipped with Audacity or some other Nyquist Vocoder?
What settings are you using in the effect?

I’m using Audacity 2.1.2, and I’m referring to the Vocoder effect shipped with Audacity.
Vocoder settings:
Distance 20.0
Output both channels
No. vocoder bands 40
Amplitude of original audio 100.0
Amplitude of white noise 0.0
Amplitude of radar needles 0.0
Frequency of radar needles 30.00

I can’t reproduce the error here.
Tell me about the track that you are trying to process.
How long is it?
According to the panel on the left end of the track: is the track stereo or mono? What’s the sample rate? What’s the format? (example: stereo, 44100 Hz, 32-bit float)

I tried a few time with two different tracks, one of 34s and another of 2m47s
According to the panel on the left: stereo, 44100 Hz, 32-bit float (for both tracks I tried with)

Do other Nyquist effects work correctly? (example: Adjustable Fade, High Pass Filter, Crossfade Clips)
Did you get Audacity from the Audacity website: http://www.audacityteam.org/download/windows/

The attached picture is the effect list.

And yes, I downloaded Audacity from the official website.

Try this:

  1. Close and restart Audacity
  2. Generate a 30 second tone, 440 Hz, Sine (“Generate menu > Tone”)
  3. Open the “Nyquist Prompt” effect.
  4. Copy this code into the Nyquist Prompt text box, then click the Debug button:
(set-control-srate *sound-srate*)
(abs-env (pwlv 0 30 1))

What happens?

Nyquist output “error: unbound function - SET-CONTROL-SRATE”

The Nyquist effects are those below the line in your picture. Which, if any of them work?
If you’re unsure how to use the effects, they are all documented in the manual: http://manual.audacityteam.org/man/index_of_effects_generators_and_analyzers.html

I think none of them work.

After attempting to run a Nyquist effect, open “Help > Show Log”.
Save the log somewhere convenient (example on your Desktop), then attach the saved file to your reply.
See here for how to attach files to a forum post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1

I’m sorry, but the nyquist effects seem to be working normally after I moved the software folder to another place, and I think the problem is due to a Chinese folder name. For example, if the Audacity folder is in a folder of English name, there will be no problem, but if the Audacity folder is in a folder of Chinese name, the nyquist effects don’t work.
Sorry for making such a fuss. If I face any similar problems in the future again I’ll seek help again.

That makes sense. “Nyquist” is a programming language that has been shoehorned into Audacity. Although Audacity supports Unicode, Nyquist is strictly ASCII, meaning that it does not understand characters that are not part of the standard ASCII character set, so Nyquist will not be able to find its source files if the path name has characters that are not standard ASCII characters.

I’ll mark this topic as “solved”.