Numeric value in amplify effect

Hie

I’m using Audacity 2.1.1 with ubuntu 14.04 and I have a problem with the amplify effect.

When I want to assign a numeric valor, I can’t write anything, with the numpad or the other keys of my keyboard (the are working very well). Curiously I can erase the numbers but I can’t write…
I have to use the cursor…
I tried with Phather filter : the problem is here too… :open_mouth:

Do you have the same problem ? :question:

Thank you

Is the problem only with the Amplify effect or other effects too?
What value are you trying to enter into which box?
Are you using the numbers on the numeric keypad, or the numbers above the letters on the keyboard?
Look in “Help > About Audacity > Build Information”. Does it say that Audacity is using WxWisgets 2.8.x or WxWidgets 3.x.x?

Thank you fer answer me :slight_smile:

Is the problem only with the Amplify effect or other effects too?

I tried with Phather filter : the problem is here too.
I just tried with echo filter, it’s the same.

What value are you trying to enter into which box?

Any one… It’s how if I don’t hit any key…

Are you using the numbers on the numeric keypad, or the numbers above the letters on the keyboard?

I can’t write anything, with the numpad or the other keys above the letters of my keyboard

Look in “Help > About Audacity > Build Information”. Does it say that Audacity is using WxWisgets 2.8.x or WxWidgets 3.x.x?

It’s wxWidgets 2.8.12

Is any body have the same problem ?

Thank you :slight_smile:

I don’t think this is a known problem. Audacity 2.1.1 works for me on Ubunty 14.04.

Where did you get Audacity 2.1.1 and how did you install it?
What language settings do you have, both for Ubuntu and for Audacity?

I installed it from :
ppa:ubuntuhandbook1/audacity

And you ? How did you installed it ?
Is there any other way for 2.1.1 ?
I’m using french for Ubuntu and Audacity.

I built it from the Audacity 2.1.1 release tarball: Audacity ® | Free, open source, cross-platform audio software for multi-track recording and editing.

This could be a very old and known hardware bug with some keyboards. Seems to happen to Adobe installers in the part where you type in the serial number. Problem happens only with numbers. Every other character works, but of course, the Audacity dialog only accepts numbers.

You could try to type a dot or comma, as these are allowed too. Just as a test.

On some keyboards, only the decimal part of the keyboard will allow you to type numbers. No good for laptops, as these usually don’t have decimal keypads.

Have you tried another keyboard?

I made tests :

1- Only the 6 key can write in effects boxes (6 - and | incluided !!!). I did not noticed it before…
2- Back space is working too. (I can delete)
3- I tryed with an other keyboard, but it’s the same.
4- I had a single additional small numeric keypad. I unpluged it and reboot : it’s the same…

I don’t understand. :neutral_face:

That makes two of us…

If the 6 works and other numbers don’t, this should be another bug.

And I can write the - and the | !!! (less and pipe)
Usualy, it’s imposible ! Isn’t it ?
But why with 2 keyboards ?

Who can inform the developers of this bug ? And How…

Do you mean “<” and “|” ?
Was that a typing error or is your “<” key coming out as a “-” ?

First we need to establish if this is a bug in Audacity, or a bug somewhere else.
So far this is the only report that we have seen for this problem, so at the moment it looks like it is most likely due to a setup problem on your computer.

What keyboard layout do you have?
What language selection do you have in Audacity? (if you have not changed it, it will be set for “system”).
What language is Ubuntu set for?
Have you had similar issues with any other applications?
Do numbers type correctly in labels? (see: Audacity Manual)

Thank you for helping me.

What keyboard layout do you have?

My keyboard is a :
Argom tech : ARG-KB-7414
http://www.compuamersa.net/zencartr/index.php?main_page=product_info&cPath=66_1005_1015&products_id=17730&zenid=j279r2m9nabss7stfp6v45sam3
It’s a simple very standard qwerty Keyboard with stickers to convert it in azerty (I’m living in Nicaragua and it’s impossible to find a AZERTY here.)
But it can’t have any link with the numpad…

Moreover, I have the same problem with my 2nd keyboard witch is a 100% french azerty :
http://www.amazon.fr/Mobility-Lab-ML300559-Clavier-Flexible/dp/B004VU7NAU
I disconnect the Argom, I connect the Mobility, I reboot and the problem still here.

Do you mean “<” and “|” ? Was that a typing error or is your “<” key coming out as a “-” ?

No, I mean - (less) and |(pipe), because on a “french keyboard”, the 6 is on the same key with - and |.

Have you had similar issues with any other applications?

No, I’m shure that I don’t have any problem with any other software. My home made azerty is working very well with all others applications (LibreOffice, Blender…)

What language selection do you have in Audacity? (if you have not changed it, it will be set for “system”). What language is Ubuntu set for?

Ubuntu 14.04 is in french (from instalation), audacity is in french (from instalation by default)

Do numbers type correctly in labels? (see: Audacity Manual)

Good idea to verify that. It’s working very well. I can write numbers normaly in labels.

It’s a mystery…

I installed it from a official ppa fund here :

I did that :

$ sudo add-apt-repository ppa:ubuntuhandbook1/audacity
$ sudo apt-get update
$ sudo apt-get install audacity

I just discovered that I can use normaly numpad and the others numkeys to fill in the text box of the track’s gain.
But but still not the effects boxes.

Could it be a problem with python? (Effects are in python, aren’t they ?)

The standard built-in effects are written in C++ using WxWidgets, which is the same as most of the rest of Audacity.

According to Wikipedia, AZERTY keyboards use “upper case” for number (AZERTY - Wikipedia)
Have you tried with both upper and lower case, Caps Lock on and Caps Lock off, Num Lock on and Num Lock off (and all combinations of these)?

I tried it in Ubuntu 14.04 in 2.1.1 release (so built with wx2.8.12) by setting input language to French in the “Text Entry” settings - this seems to produce AZERTY layout. I can type numbers in effects by using SHIFT so please try that.

Using SHIFT to type numbers in effects works in our current code too, which has changed to use wx3.0.2.

Our current code has a problem in wx3 with label tracks which I will put on Bugzilla. There seems no way to type numbers in labels in AZERTY layout. Using SHIFT still produces letters like lower case does, and NUMPAD number entry does nothing. NUMPAD also does nothing in labels in English/QWERTY.


Gale

I am also having this problem on both my desktop and my laptop, in particular, the inability to enter numbers in most effects using my US keyboard’s numeric keypad. This is true whether I use the Audacity 2.1.1 packages from the ubuntuhandbook1 ppa or compile it myself. I am running Kubuntu 14.04 on both systems. Unfortunately, this is a showstopper for my workflow as I regularly process hundreds of samples, making frequent use of the numeric keypad. I have gone back to 2.1.0 for now (self-compiled), which works just fine.

Gale Andrews, please let me know if I can provide any helpful information on this case.

Which effects have this problem and which don’t?

Using what Keyboard layout? Have you customised the layout in some way?

I have a UK keyboard so I can only simulate other keyboards by changing layout in Settings.

Ubuntu Handbook build Audacity with wx2.8.12. Did you compile Audacity yourself with 2.8.12? I am not aware of a problem with NUMPAD in effects on Linux with Audacity built using wx2.8.12 or wx3.


If so then it must be “something” to do with the new input validation I guess, unless as Steve suggests only one or two particular effects are involved.


Gale

According to KDE, my keyboard layout is “English (US)”, with the map “us” and the keyboard model reported as “Generic | Generic 101-key PC”.

It was compiled using wx2.8.12.1. Should I try it with wx3 instead?

I went through all of Audacity’s effects plugins (“Amplify”, “Bass and Treble”, etc.), and most of them fail to accept input from the numpad. The exceptions are “Noise Reduction”, “Nyquist Prompt”, and “Reverb”, which work normally.

How about the “Repeat” effect? (Audacity Manual)