Novation Nio USB Audio/MIDI / Audacity

Help please !!!
I’ve recently bought a Dell Inspiron 530 with Realtek onboard sound. Its a Intel E7300 Dual core 2.6ghz, 2 Gig DDR2 RAM with Windows XP SP3.

I bought a Novation Nio 2|4 audio/MIDI USB interface to plug all my music stuff into from a Spirit mixer. I run Cubase VST5.1 and the Nio transmits MIDI signals and records audio absolutely fine… i’ve got it set up to use the Novation ASIO driver

…but when I come to use Audacity I’ve hit a very big brick wall. I’ve used Audacity many times over the years on my old PC which had an Audiophile PCI soundcard using the ASIO drivers for it. And all was roses in the garden.

I’ve found another post in this forum saying about ASIO drivers and Audacity not getting on too well… Is this whats going on here?? I’ve been on to Novation Tech support and the guy there tells me that he runs Audacity on his PC running XP SP3 and a Nio so he must be using the ASIO driver for it too. He can’t really give me any more advice than 'have you checked the settings?". If I check the settings again and try any more combinations of default devices, I’m going to explode!

I’ve done many different things to try to solve this including…

Uninstalling the Nio and Audacity and reinstalling, disabling the Realtek onboard sound through Control Panel and through the BIOS settings, trying different combinations of Microsoft Sound Mapper, Realtek input/output and Nio, swearing, crying and some close attention with a large hammer…

But still nothing.

Interestingly, Audacity will not record even when the default devices are set to Sound Mapper or Realtek. The cursor moves but only seems to pick up electronic rhythmic pops and clicks (or is that just the music that I make…) And when the default devices are set to Nio the cursor sometimes absolutely refuses to move and just sits blinking at the 0.0 position. If the cursor does move across the screen, then when it reaches the end of the screen (13.0), it just disappears but the screen does not change to show 14.0, 15.0 etc. Even bypassing the Nio by plugging the mixer into the Realtek input on the back of the PC doesn’t work (just the same pops and clicks…)


If this is just an Asio driver conflict, what can I do about it???

And if its not possible to get around it can anyone recommend software that will do the same thing as Audacity including recording streaming audio.

Please help me before they send round the nurse and the white van again…



Audacity is not (and never has been) distributed with ASIO support. (Audacity is prevented from including ASIO support in the compiled binary files due to licensing restrictions).

However, for most ASIO devices there are also Windows drivers (WDM drivers) available. These should work with Audacity. Sometimes the WDM drivers are included in the default install of the hardware, but sometimes they must be added as a post install optional extra.


Thank you for your reply. I really appreciate the info…

I was beginning to think I was going mad…!!!

I will get on to Novation Tech Support and see if they can help me.

…but I still don’t undertand how my old Audiophile PCI soundcard worked with Audacity cos that was set up to run with ASIO drivers and the guy at Navation Tech support told me that he used Audacity with his Nio.??? …its all too complicated for me …!!!

Again, many thanks


You must have also had Windows drivers installed as well as the ASIO drivers. (You can have both installed and ASIO compatible programs will use the ASIO drivers, while non-ASIO programs will use the Windows drivers).


On my old PC (XP SP2) maybe I was lucky that it all set itself up with no problems … but thanks again…

… and just in case this is useful to anyone else, I’ve now found that if I pull the USB cable out of the Nio (before switching the PC on) and then set all the default devices to the Realtek integrated sound, Audacity works absolutely fine…

Thanks Steve



Apologies if I’ve missed something (coming to this thread a little late…) but I’m having the same problems with Audacity not recording from the NIO audio source.
I’m not trying to use the MIDI yet, just want to record audio but it’s not progressing the audio track (as you described).

Did you manage to find a solution to this or was it just the MIDI you wanted to fix?



Windows will (usually) automatically pass control over to a USB device when it is plugged in. If you plug in a USB audio device, then Windows sets that as the default device for recording and playback, thus effectively disabling your on-board sound card.
Your on-board sound can be re-enabled from the Windows Control Panel (Sounds and Audio Devices).

Audacity does not support MIDI, it is an audio program, not a MIDI program.

Yes, but the actual problem I’m having is that the cursor sits at 0.0 during recording and never moves.
I have installed the latest Novation drivers for the NIO (the original drivers supplied on disc do manage to record something but only for about 5 seconds before the entire machine locks up and I have to force a hard reset).

I take your point about the MIDI. :blush:

Make sure that you have Windows drivers installed (WDM) - Audacity does not work with ASIO drivers.

Which version of Audacity are you using?

I actually tried both the latest 1.2 and 1.3 beta - same result.
Also tried recording using windows’ own ‘recorder’ tool and got nothing so I really don’t think this is an Audacity-related problem - I was interested to see how the original poster solved what sounded like the same problem I’m having with the NIO.

I also know it’s not Adacity because I can record via the on-board sound card directly into Audacity (but that gives me a whole range of latency and quality issues, hence the NIO).

Not sure how to check it’s using the WDM drivers and not trying to use ASIO drivers though so all advice gratefully received!