Not working in iMac mavericks

I cannot get Audacity to work in Mavericks. I am trying to record phone calls, as I have for years on an older iMac. I have tried a USB microphone adapter. I have tried two KV Connection audio devices connected through the headphone jack. The most recent shows in the preferences sound settings as an external microphone but audacity does not recognize it.

What devices work with Mavericks? USB or into the headphone jack.

thank you. Deb

The older iMac probably had a Stereo Line-In like the connection on the left.

The new ones don’t have that anymore.

USB microphone adapter.

That doesn’t tell us very much. Connecting to a telephone is scary and there are a number of ways of doing it. How are you trying to do it? Details, part numbers and descriptions are good. We can’t see what you’re doing.

Details like do you have a landline phone? How are you connecting to it?


This is how I do it.

That’s a special bidirectional microphone.


One quick note. Connect USB devices and then start Audacity. Audacity checks for new devices when it starts.

I am using a landline with a Radio Shack Telephone recording control # 43-228A.

I connected the Microphone cable before starting audacity.

Is it against the rules of this forum to say what you have used successfully?

Thanks Deb

It’s an Olympus TP7 recorder.

USB adaptor is USB to Stereo Audio Adapter Converter - USB Audio Adapters | Add-on Cards & Peripherals | or similar.

So are you connecting a tape player to a USB adaptor? Which USB adaptor (make and model number)?

Have you restarted Audacity after connecting the USB adaptor?


Apparently, that’s a discontinued unit. It doesn’t appear on the Radio Shack web page. I found the use instructions on-line.

I suspect you are a victim of the iMac wanting to “see” the right things on its connections before it will work. I can’t prove that, but a number of other Mac services work this way.

I would expect a device like my little USB Startech would work with the phone adapter’s sound connection plugged into the Mic-In. It appears in Apple (upper left) > System Preferences > Sound > Input (Attach 1). Once you get it that far, start Audacity and look for it in Preferences > Devices > Recording (Attach 2).

Please note while you’re still in Apple Preferences, you should be able to get the blue ball sound meter to jump when you make a call. Audacity depends on the computer. If the computer can’t see it, then Audacity will never see it.
Screen Shot 2014-08-24 at 1.13.54 PM.png
Screen Shot 2014-08-24 at 1.12.22 PM.png

I think I have one of those phone adapters and if I can find it, I’ll see if I can make mine work. I was never able to get it to be well behaved before, so I put it in a box.


What I find interesting is that the computer “sees” the “iPhone 1/8 inch microphone adapter - 3.5mm 4 conductor TRRS Male to 3.5mm Microphone Input Jack” that KV Connections sold me, but Audacity does not see it, even after I quit audacity and reopen it. It continues to give as the only option “built-in microph”

With this adapter, the blue ball in the Sound Preference sound meter jumps around like crazy when I make a call.

I will order a star tech.

Thank you.


Does that headset port still show up as an output device in Audacity? Does Garageband record from it?


The output devices says “headphones” and type “headphone port.”

Garage Band appears that is recording, but nothing plays back.

With this adapter, the blue ball in the Sound Preference sound meter jumps around like crazy when I make a call.

So the machine knows what’s going on, but not Audacity. That usually happens on Windows machines with certain multi-channel soundcards that require special software.

First I heard of it happening on a Mac.

Just to cover the bases, try the Audacity Long Form. Audacity > Preferences > Devices > Recording. Sometimes Audacity will ignore devices if the Stereo/Mono is set wrong.


No, it still does not recognize the microphone going through preferences. I tried changing from mono to stereo and back. No response. I will order one of those Startech USB adapters. Thanks for your help. Deb

I am writing again to report the Startech USB external stereo adaptor is still not allowing me to record using Audacity. The sound preference panel recognizes the device, saying “USB PnP Sound Device.” Audacity also allows this device as an option. But when I go to record, nothing happens. I get a flat line and nothing is recorded or will play back. I have turned the microphone volume all the way up.

I am using the same radio shack telephone recording device, 43-228A. It works fine on my older mac.

Please let me know what else I can do, try.

Thanks, Deb

Here’s my Startech working with a plain electret microphone. The Mac System panel with the blue ball sound meter and the Audacity red Record and Green Playthrough meters all working. Do you see anything in that picture that’s different enough to cause problems?

One quick note. That’s Monitor Mode in the picture. You can go into full record to do a sound test, or you can Control-Click on the red recording meters > Start Monitoring. The meters will wake up and start measuring the sound coming into Audacity. It’s not obvious it’s going to do that and it’s really handy when you have a recording problem.

Your iMac has a built-in microphone, right? Can you record from that?


I don’t remember if we covered this, but plug in the USB equipment and then start Audacity. Audacity checks for new equipment when it starts.


The only thing I see different is the blue bar does not light up at all.

My mac does not have a built in microphone, that’s the problem. The old one did.

I have plugged in the USB star tech device and then started Audacity.

When I control-click on the red recording meters, the left one moves a little bit. But it will not record.


Do you have a mic to connect to StarTech to test if the latter is working?

Have you tried all the USB ports?


No, I do not have another microphone to try connecting it with. This device is working great on the older mac.

I tried all of the USB ports.

I’m stumped.

Thanks for your help.