not responding

Since updating to the newest Audacity I have a problem with constantly " not responding " whenever I try to copy and paste. Does anyone have any solutions please.

1 Like

Sorry should have said, Audacity 3.2.1, and windows 10.

This could be because when audio is copied to a second location within the original project, only a pointer to audio information is copied; however when audio is copied to a completely different project, ALL of the underlying audio information has to be copied.

So what happens, if you try to copy a very small section (e.g., 30 seconds) of a very long clip (e.g., 60 minutes) to a New Project, is that the entire 60 minute clip gets copied but only the 30 second windows is visible. There are two issues with this: 1) It takes a long time to copy a 60 minute track, and 2) the New Audacity Project get unfairly bloated.

So here is how to fix the problem. Select-copy the audio you want but first Tracks > Add New, and paste into the new track in the original project. Then Tracks > Mix > Mix and Render, and then select-copy the mixed track and paste to the new project.

This issue is one the devlopers are currently addressing and are hopeful to have a solution soon:

Another workaround:

  1. Ctrl+S to save your project (so you can revert if things go wrong) - or use the File>Backup command

  2. Select the audio you want to copy to the other project

  3. Ctrl+T to trim the audio leaving just the clip

  4. CORRECTION: select and delete in turn each side of the required “clip” for copying

  5. Ctrl+C to copy to trimmed clip to the Audacity clipboard

  6. Ctrl+Z to undo to restore the full audio - CORRECTION, need to do this twice to restore the two deletions

  7. switch to the other project

  8. Ctrl+V to past the trimmed clip

Note that trimming the temporary clip in this way will not create a so-called “smart clip” with all the audio of the original full clip or track, rather it will contain just the audio that was selected at steps 2-4.


What version are you running? For me on 3.2.1, it creates a “smart clip”.

OOPS yes sorry Trim does make a smart clip. :blush: :blush: :blush:

So what you need ti do is delete before the small required clip and delete after the required clip - THEN you don’t get a “Smart-clip”.

You need a couple of undos to get the full track back - and a temporary range label for the required “clip” helps as you get the yellow snap guides to aid the selections.

I updated the instructions


Thanks to everyone for responding, but I’m more confused than ever.
I have 2 projects, one new the other old.
No.1 [ the old one ] is 5 mins long and has a size of 51kb.
No.2 is 17.5 secs long and a size of 1504kb.
I’ve tried changing the large one back to 16 bits and closing it but it doesn’t make it any smaller.
I have used Audacity for years and really like it and appreciate all the hard work that Audacity do behind the scenes, but it strikes me that the new upgrade has, for some reason, shot itself in the foot; it reminds me of Windows 8.
I’m unable to understand the reasoning for saving the whole file with every small copy and paste clip, perhaps some one could explain please.

Well, I can at least try. Others may also chip in.

So this is incorrect. The old “xyz.aup” file may be 51kb, but the whole project is going to include that xyz_data directory containing perhaps 50 “tiny” 1 MB files, for a total of around 50MB. This confusion is closely related to the “unification” project where everything is now in a single .aup3 file.

The .aup3 project is a “database” file and is managed by a sqlite3 database file manager. It only has to write out one small block at a time. So Audacity can bypass the overhead of the operating system’s file system manager and should perform very well, locally. Should your file be stored on a remote “cloud” server, there may be delays or other undesirable issues involved, possibly including “Not Responding”.

“Improvements” in 3.2 to a feature called smartclips introduced in 3.1, allow for a pointer to the entire original clip to be copied, even when only a very small part of the clip is being copied and pasted. The problem arises when only a tiny selection of a very large clip is copied to an altogether different project. In this case, the entire clip is, perhaps erroneously, copied to the other project, resulting in severe project bloat and again the “Not Responding” condition.

Here are the takeaways:

  1. Avoid copying a tiny selection of a large clip to a different project. If you must do this, copy it to a new track within the old project, then do mix and render. Then select and copy the newly “rendered” clip or track to the other project.
  2. Avoid working directly on remote or cloud-based storage. If you must work on a project that is being stored remotely, make a local copy and work with that. Then, copy the project back.

Thanks for the reply. Unfortunately I couldn’t understand most of it [ my fault not yours ]. All of my storage is on my P.C. I don’t use external so that won’t affect the " not responding" problem.
I think I might just revert to the older version if I can, it worked for me. While I’m sure the " improvements " will be of benefit to some they seem unnecessarily complicated for my needs. Thanks again for taking the time to answer my query.

Since the most recent update there’ve been numerous issues that make using Audacity a hassle, when it has–for the past 10 years–been a breeze. The worst and most impactful is the simple act of cutting or copying and pasting even a, say, 2- to 3- minutes excerpt of a 20-minute stereo track into a new project. This used to take seconds. Now, first, nothing happens; then after a couple of minutes the screen goes white and it says “Not Responding” for up to 30-40 minutes. This is irksome to say the least, and obviously not “necessary,” since all prior versions of Audacity did not have this same issue. I hope you will fix it. I’ve been a fan and evangelist of Audacity for some time but I don’t have time or patience to wait 1/2 an hour to simply add a 2 to 3 minute clip to a new project.

There is a pending fix for this which hopefully should make it into the next release. When making such a copy it will ask if you want to copy just the selection or the whole “smart clip”.


I have tested this in the branch build of the developer who is working on this and it worked fine in that branch build.