"Not Responding" and very long delays.

I record very long audio tracks, some times up to 15 hours or so, and that in itself maybe the problem but I wonder if there is a fix or work around.

All it takes is a single click, for any reason, and I get “Not Responding” at the top of the screen and I have no access to the program for 5 - 6 minutes. If I click a second time the screen goes grey. Eventually, access returns and I can click again for a repeat of the pattern. Sooner or later, I can complete my task but it can add 30-40 minutes to the session.

I thought of stopping the recording hourly and make additional tracks but I am not sure that will help.
The system records fine under any of these conditions so as far as production is concerned, there are no losses.

I will continue to make these recordings as once they are done, they play with no problem. After I replay them they are erased. There is no editing, just record and play.
The system is new and there is plenty of disk space, memory, and CPU speed.
Virus and malware checks indicate a clean system.

Any solutions for this?

Chances are good you’re waiting for Audacity to transfer the work from temporary space to the final resting place (so to speak). You can avoid that gap by saving the project once at the beginning and then go on to the final show, saving it again when you’re done. Audacity will then be writing the show directly to the final location.

Not having tons of memory is also contributing to this gap. Once Audacity runs out, it has to juggle your show from the hard drive and that can be like slogging through sand/snow.

Koz

I thought about that but when I save, exit, and bring the recording back, the delays are still there.

Now you need to throw data. Which operating system, which Audacity (all three numbers)? Early Audacity versions would not go over 13 hours, so you’re (probably) in New Version Services territory.

Koz

Audacity 2.1.1
Win 10
I probably did the installer. Is there any way to determine this?
I do not recall if this happened in Win 8.

I probably did the installer. Is there any way to determine this?

We’re good.

when I save, exit, and bring the recording back, the delays are still there.

That’s very different from the original complaint. Taking a week to open a 15-hour Project fresh is normal. Audacity Projects are saved in super high quality. They’re not just CD Quality WAV files. This is done so you can apply effects and filters without worrying about overload and multiple generation quality damage.

The down side is the show data size.

Koz

Hmmm, complaint is a bit harsh here. I have full confidence in Audacity. If slow response is the result of 18 hour recordings then so be it.
I was just wondering if I had over looked something or if others may have seen this same result.

The situation has not changed from the original question though. It is all based on these extremely long delays. Every time there is one, the term “Not responding” is at the top of the Audacity page. It is there with every click, upon opening a saved session, etc.

You do make me think of a possible solution though. I am going to look into saving all this at a much lower resolution. These are all talk shows and not music. No editing or special effects will every be used on these files.

I will check this and post the result.

I know the solution is staring me right in the face…

I just created a mono pink noise Project 10 hours long. The _data folder is over 3GB. It opens from a fresh desktop (double click the AUP file) in about a second. I’m doing this on a clean Mac with solid state drive, so nothing takes me very long, but still.

We have had times when the virus protection insists on inspecting everything as it goes by. That will add processing time.

Try what I did. Open Audacity. Generate > Noise > Pink: 0.5 amplitude, 10 hours. My track settings are attached.

Save the project when it gets done 10HourNoiseTest to the desktop. No punctuation marks or spaces.

Close Audacity. Double click the aup file. What happens?

Koz
Screen Shot 2016-04-22 at 20.21.36.png

You’re on Windows. What’s your hard drive light doing during all this? Disco light show?

How big is your drive and how full is it? Spinning metal?

Koz

Rare occasional blink on the HD light. 254GB free of 915gb
I am setting up the 10 hour test and will report in the morning.
BTW: I have been using the Mono setting all along.

It works like a charm. I even pushed it out to 20 hours
Copy/paste, Cut paste. move to the beginning middle or end. All in a fraction of a second each.
My settings show Mono, 4410HZ, 32-bit float: The same as when I an recording radio.

Very interesting,…

FYI: 8 gig memory and nothing else running on the system when I am recording. 64bit operating system x64-based processor.

It’s nice you’re running 64 bit, but Audacity (as far as I know) is 32-bit.

So it seems to be a time-related failure.

My only experience that maps to this problem is a memory checker. There is a program that loads into the machine in place of the regular OS (It used to be on a floppy) and once started, it pushes very precise, specific patterns of ones and zeros (with funny names) to whatever memory it’s not standing on. It is very strongly recommended that the test be run multiple passes, such as start it when you go to bed.

Windows MemCheck failed at 04:35, pass 20, Leaping Frog pattern at location 14, memory stick 3.

Running the tester only once is nearly a complete waste of time. This example failed some five hours after I started it.

I have no idea what could cause a very long project to be damaged in a way that just makes it sluggish rather than crash. Possibly the machine is hot right after the recording and is in heavy error correction and recovery. When you’re doing production like that, the hard drive has no chance to spin down and cool off. I don’t remember the number, but something like every ten seconds, Audacity writes to the drive. In your case, forever.

I’m completely dreaming up possibilities. I have no idea what’s wrong with the machine.

Koz

And it does it with such incredible consistency.
Short recordings work perfectly without delays.

When I play them, I tend to delete that which I have listened and save the balance. It can get down to 3 hours and I save it but still takes 3 minutes to load, 2 minuted to get to the end of the track when I hit . It looks as if what ever is affecting the track is saved with even a fragment of that track.

It is interesting that 20 hours of pink noise ran without any indication of any problem. I will be trying the next recording with lower resolution to see if it makes any difference. Since I will be recording in real time I willl not see the results until late tomorrow night.

If you had been editing, I would have suggested Tracks > Mix and Render.

There are many ways Audacity is slow with long projects, but I am a bit surprised by just click causing an issue, because even in 2.1.1 that click action no longer writes any data - in older 2.x.x versions the click would scan the data and write an “autosave” file so as to save the cursor position.

Does 2.1.3-alpha help? Try the top build gaclrecords.org.uk.


Gale

I willl not see the results until late tomorrow night.

I know this is just the most fun you can possibly have, but it would be interesting to narrow it down. Such as: It does this time delay thing whenever the live recording goes over eleven hours, seventeen minutes and forty-five seconds. That’s clearly a software trigger happening in the wrong place. If you can only determine the failure to the nearest one or two hours, I’m going with a heat/hardware problem.

The computer people have a fancy-pants name for this (successive approximation?), but do a test recording half as long. Then divide the result in half again. For example, if 6 hours doesn’t fail, make one half-way between 6 and 15. If it does fail, go for 3 hours.

Koz

Taking a week to open a 15-hour Project fresh is normal."

Wow, I certainly hope this is not the case.

What setting are you using under preferences import/export copy or read from original location? I have just done some tests with several very large files (greater than 4 GBytes) opened simultaneously and I can’t get audacity (32 bit version) to consume more than about 95 MBytes of memory so it does imply a lot of disk use. If you have plenty of memory to spare you could try using a virtual disk (ram disk) for audacity temporary files and even to test reopening a project that is copied to a virtual disk. There are a few free options for ram drives for example :- http://www.radeonramdisk.com/index.php.
If this does give a significant improvement and you need greater temporary file space you could consider using a sata solid state drive for temporary file space.

Wow, after all these years of fighting with this problem. It is cured and it was so simple.

Since I no longer trust MS and backups, I designed my own technique. Everything I do saves to a network drive. I backup (rather copy) that information to another drive as a back up. As a result, the Audacity files were going there too. When I saved them to the C drive, everything cleared instantly.

I am sure that others are making network asving work and there may well be a fluke in my network but the problem seems to be gone and I don’t care…
Trying to get that timer delay-start to work is not so much of an issue but it would be interesting to see why it never worked for me.

Mischief Managed.

Emerogork,

I’ve been discussing this bug with one of the developers, he still doesn’t understand why this happens, but he has his suspicions and has an idea for a change to the code that may make this problem go away.

If he develops such a “fix” would you be prepared to test it for us - as you are one of the two users for whom this seems to happen consistently?

Peter.