not recording

I have weird problem used to be able to use my PC to record what I wanted. Then I upgraded to 2.0.5 and wanted to record some interview.
All of sudden my audacity is not recording. I did not change any settings. It all looks the same.
I went through all settings and it all looks ok to me but when I record I just get flat line. I can play but I cannot record.
I am using AudaCity 2.0.5 have Win7
Any advice would be helpful (I went through all advice on wiki page)

Then I upgraded to 2.0.5 and wanted to record some interview.

Take us through how you’re recording the interview – keeping in mind we can’t see you. USB Microphone? Headset? On-Line interview? Plug in a field sound mixer? Record Skype?

One very common problem is plugging a USB microphone in after starting Audacity. Don’t do that. Plug in the microphone and then start Audacity.


I start audacity
On the Device Toolbar
Audio Host – MME
Output Device – (speakers are selected as output)
Input Device – microphone (What U Hear)

Then I just try to play with my winamp any kind of music and I am getting flat line, or I open browser and play interview that is in flash,
I can hear the music playing how ever audacity is not picking up any kind of input

I’m no help. I’m having the same kind of problem with a new installation on a “new” Win7 laptop. I’m trying to replace an old desktop that still works, but only marginally. The desktop works, but the laptop shows in input from the USB. I’ve installed Codecs, drivers, etc. but to no effect.

Today I had some time and wanted to try few things in order to get audacity to record for me again

I kind of tried all sorts of input etc. Nothing helped then I removed 2.0.5 and reinstalled 2.0.3 that did not help at all

I will now try some other software out there and let you know but I can not figure out why is audacity not recording sound from my PC

The problem is probably not Audacity.
It sounds like Audacity is trying to record, but no sound is coming to it from the sound system, so it has nothing to record (It can’t “hear” what you can hear).

The problem that you need to fix is to configure the computer sound system so that Audacity can “hear” what you hear.

I presume that you have some sort of SoundBlaster sound card?
What sort is it?

What settings are available for the recording input settings?

Have you reinstalled Audacity 2.0.5?

Hi Steve I would tend to agree with you
What is driving me nuts is that I can not figure out why all of sudden Audacity is not hearing what I hear

So I have Creative SB X-Fi
I added pictures of my recording settings and audacity settings let me know if it looks out of place

Looking on Google, you’re not alone.
“What U Hear” recording not working seems to be a fairly common problem with the X-fi.

Try deselecting “Digital In” as the default communication device.

What have you got on the playback tab of the “Sound” panel?

Were you playing anything when you made those screenshots? There is no indication of a signal for “What U Hear” (no green bars).

this time I was playing and recording while taking pictures
What U Hear is showing no bars

I removed the digital in
the weird part is that I have no idea what has changed (from my perspective nothing)

Well at least that explains why Audacity is not “hearing” anything - There is nothing for Audacity to hear.

Right click on the “What U Hear” icon and select “Properties”. Check that the recording level is turned up.

Rather than using MME as your host - try using the new host WASAPI loopback - see:

This works well for me on my W7 laptop


It looks that my sound card is not working fine

I tried quite number of things to get my sound card to start recording but no luck

any recommendation on mid range quality sound card