Not recording. [SOLVED]

Hello all,

I’ve plugged my cassette tape deck (RCA cable from “out” into blue “line-in” at the back of the computer), played a tape, which I can hear because “software playthrough” is enabled but when I hit Record I get “Error opening recording device. Error code -9999 Unanticipated host error”.

I’ve reset Audacity to default everything and tried all the different options in the Device toolbar.

Help. Thank you.

Windows 10/Audacity version 2.4.2

Can you record from anything with Audacity (for example, if you have a laptop, can you record from the mic)?
Have you ever successfully recorded anything with Audacity on this computer?

Hi Steve,

Thanks for getting back. I’ve got a tablet with a mic so I’ll try that.
I have used Audacity on this computer before but not for a long while (years maybe). I recorded a few albums successfully using the same cables, but they came “out” of the turntable via RCA and “in” to the computer using a USB connection. I tried using the USB input with this latest device but it didn’t work. The only way I could hear anything was by using the blue “line-in” at the back.
If there’s a simple solution I’d be most grateful.

Cheers, Dave.

So there’s probably been quite a few Windows Updates since then?

Over the last couple of years, Microsoft have made big changes to “Privacy” settings. You now have to give permission for apps to access the “microphone” (Microsoft use the term “microphone” to mean “any recording device”). See: Turn on app permissions for your microphone in Windows 10 - Microsoft Support


Cheers, that worked. Happy bunny.

Thanks, Dave.