Not Recording from Any Input [Possible Bad Windows Update]

Here are all of the particulars:

OS: Windows 7 Ultimate 64-bit
Mic: Blue Snowflake USB Microphone
Audacity Version 2.0.5

Last night (March 12, 2014) I was able to record sound from the Blue Snowflake into Audacity without problems. Before going to bed, I shutdown my PC, noticing that it had the “yellow shield” next to the Shutdown button, indicating that Windows Updates would be installed before the PC turned off. This morning, I tried to record sound in Audacity, and nothing happened. The meters won’t move, the waveform doesn’t fill up. I changed my audio settings in Windows, verified that the mic is plugged in, detected and works. I can enable the “Listen to this device” feature and I can clearly hear the mic input through my headset. So, I’m thinking that one of the Windows Updates from the latest Patch Tuesday broke something in Audacity. I’ve tried everything I can think of, short of uninstalling every patch that was installed. I’ll check my updates, and try to rule out the bad patch, but hopefully someone here can point me in the right direction, as I am completely flummoxed by this.

Restart Audacity. Audacity looks for devices on startup and the update could have killed its connection.


Firstly, sorry for the double-post, but I couldn’t find a way to edit the original. I did find a passable solution. First, I checked the updates that had been installed from the latest Patch Tuesday. (See Attachment). I went through and uninstalled each of them, restarted. That didn’t fix the issue, so I did a system restore to a point earlier last night, before I had shutdown and installed the updates. That did fix the issue, and I can now record audio in Audacity, again. I’m still not sure which update broke it, but I would advice that if anyone has the same issue, they perform a system restore to a point before installing the updates from 3/11/2014, and avoid those patches until it can be confirmed that they do no cause issues with Audacity.

A mod can otherwise tag this as [Solved], if it so pleases.

I tried that, naturally, as well as reinstalling Audacity completely.

A good test can be to make the offending device the default recording device in Windows Sound, then try recording it with Windows Sound Recorder. If that records silence then it isn’t an Audacity problem.

You can read details of the critical and important patches here: .

“Vulnerability in Microsoft DirectShow Could Allow Remote Code Execution (2929961)” is about JPEG images so not likely to be relevant.

Perhaps the problem could be .