not recording anything

I am using the podcastudio with audacity. When I try to record, it gets no sound. If I unplug the usb audio interface it will show imputing sound. must be the computer mic. how can I change this.
To be more specific I am using a behringer xenyx502 mixing board.
someone help this not so tech savvy person so I can make some podcast!

How is the Behringer xenyx502 connected to your computer?

As in red near the top of this page: Please state which version of Windows you are using, the exact three-section version of Audacity from “Help > About Audacity”.

Running on Windows 8.
The 502 is connected with the usb audio interface, behringer uca200.

The version of Audacity (all three numbers)?

Connect the UCA and make sure Windows sees it before you launch Audacity. Select the UCA as input device in Device Toolbar .


Version 2.0.6
When I try to configure the mic through control panel, sound and hardwear,manage audio devices both playback and recording are set to usb audio codec. Input is set to uca. Still not getting sound to audacity program though.

Do you mean in the device toolbar?

Try plugging your headphones into the Behringer 502. Can you hear sound there?

What are you getting in Audacity when you try to record from the 502? A flat line?
If so, try applying the Amplify effect to the recording. Does that do anything? If so, what?

If you tell the computer to pay attention to the USB for both playback and record, the computer headphone connection may very well drop dead. That sound is playing back out to the mixer (where you told it to go).


If I just plug in the headphones to 502, yes I hear myself talking through the mic. Then I hit record on audacity and it’s just flat line. In the device toolbar yes imput is set to mic. If I monitoring the mic channel it does not register any sound.
When I try to configure the mic in the computer settings(not in audacity program) my computer shows it as a usb speaker?
When I apply the amplify effect it is not a flat line but a fuzzy humming sound.

That may be the wrong settings.
Ensure that the USB mixer is connected before you launch Audacity, then look in the device toolbar and tell us what options are available.

Mixer connected before audacity is opened. In the device tool bar I have four boxes,left to right. First box audio host, three options. Mme,windows directsound,windows wasapi. Next box playback device. Three options Microsoft sound mapper-input, microphone (usb audio codec), microphone (conexant smartaudio. Last box recording channels. Two options (mono) recording channel, (stero) recording channel. I have them set to. Mme, usb audio codec, usb audio codec, mono recording channel.

Do you mean speakers (USB Audio CODEC)?

Is the Xenyx 502 the USB version of the mixer? If not, what is the second USB Audio CODEC for recording? Two identically named USB Audio CODEC inputs could be a problem.

You can rename either of the USB devices in Windows Sound, but why not keep it simple? Don’t connect any USB audio devices except the UCA 200. Connect the Xenyx 502 to the UCA 200. Restart Audacity. Then choose the only USB Audio CODEC in the “Recording” section of Device Toolbar.

If you want to send playback to the UCA 200, choose the only USB Audio CODEC in the “Playback” section of Device Toolbar.


If you looked at the aforementioned podcastudio you would see there is only one usb connection to the computer which both playback and recording is supposed to go through. Maybe none of you looked at the kit, and then just started shooting me solutions? Free help is free though right. Any rate f this 502 piece of poo. I’m going with a different audio interface, one that’s idiot proof hopefully.

I did not mean anything, I coppied everything in the device toolbar letter for letter and punctuation mark for punctuation mark.

Thank you to all that tried to help!

We don’t know what kit you have unless you are specific. You just said “the podcaststudio”. So you have this: ?

Sorry if I misunderstood about the two USB audio codecs when you mentioned it at the end. It was confusing because first you appeared to say that the USB playback device was called USB microphone. Then when you list

Mme, usb audio codec, usb audio codec, mono recording channel

you don’t mention the USB microphone, which made me think you had two USB audio inputs.

This stuff is hard when we can’t see your computer. We should probably have asked you to post the contents of Help > Audio Device Info… (top right of Audacity) then you don’t have to write anything out longhand. Feel free to post that info if you want.

Do you have the mixer configured to send sound out to the UCA? Here is the manual for the mixer . Are you sure you are connecting from the Main Out of the mixer? Then look at “2.3.4 Signal assignment” in the mixer’s manual to set the switch correctly.