Not playing clipped files properly

When I’m trying to open some really loud files, they don’t properly work in audacity. Instead it’s just white noise, if I’m trying to save them they turn into white noise too. Originally they are clipped, but other programs can still play them and get the original sound, like ear rape version of the song, but still recognizable. This didn’t happen when I used older version on windows 7 before.
Also making files +36db or louder with EQ is fine while file still isn’t saved or opened by other players. However when I open this file in audacity it turns into a white noise.

Edit: Problem doesn’t appear on wav files. Perhaps it’s some mp3 import problem?

if I’m trying to save them they turn into white noise too.

If you WANT a clipped file try the Distortion effect with the Hard Clipping option.

0dB is the “digital maximum” and anything above that can potentially clip. Regular (integer) WAV files and CDs are hard-limited to 0dB. Analog-to-digital converters (recording) and analog-to-digital converters (playback) are also hard-limited to 0dB.

Audacity uses floating-point internally so there is virtually no upper (or lower) limit. The same goes for floating-point WAV. You can boost a file to have +36dB peaks and save it as floating-point WAV and it won’t clip. But you will clip your DAC if you play it a “full digital volume” and that would be a silly thing to do.

MP3 can also go over 0dB but there seems to be a limit and it’s “bad practice” regardless of the format.

I’m sorry, I’m not good with the terms.

I meant I didn’t want clipping and white noise, I want “clean” mp3.

I tried using 2.21 version with 3.99 lame ver and It seems fine. Files didn’t turn into white noise anymore. Any ways to make it happen in recent ver?

I meant I didn’t want clipping and white noise, I want “clean” mp3.

Then, why are you boosting by +36dB? :open_mouth:

I mean I make some ear rape files for memes, but I want original audio to be somehow recognizable, like with wav files or older lame, not just white noise.

Are these files that you made? If so, how did you make them?

That can happen if a file is named with the wrong file extension.

Yes, it’s files that I made louder in the audacity. In the new version especially. They seem to work fine in any other program, but audacity just shows and plays them as a wall of white noise.
Doesnt’ get this problem with 2.21 ver with 3.99 lame. Files are 0db peak, but they don’t turn into white noise anymore. Also I i’m saving them in wav they also work fine even in new version.

:confused: So would it be possible to post some short clips to illustrate this problem? :smiley:

I apologize in advance for your ears, lol

1 was made with new version, 2 with old

If you go over 0dB things can sometimes be unpredictable…

If you want predictable-repeatable results, here’s what I suggest:

Export as regular WAV first (not floating-point WAV). That will give you hard clipping at exactly 0dB. That may sound different than it sounds in Audacity If you’re not playing-back at full-digital volume, but once it’s saved and clipped it should sound the same when opened and played-back with any software.

Or you can hard-clip with the Distortion effect. As long as you clip at or below 0dB you should get the same sound in Audacity as the exported file and the exported file should sound the same everywhere.

Then if you want MP3, open the WAV and export to MP3 (without doing anything else). The MP3 will probably go over 0dB because MP3 is lossy and the wave shape changes making some peaks higher and some peaks lower, but the sound should be more consistent.

OK, so when I played 1.mp3, I heard the static you were talking about. When I played 2.mp3 I think maybe I heard something else.

Once you go above 0 dB, the results are by definition, undefined. Audacity converts everything to 32-bit floating-point internally, trying to protect you from yourself. Ironically in this case, it seems to backfire.

VLC, for example, seems to have similar issues.

I would suggest sticking to existing distortion effects or trying what DVDdoug suggests.

I hope this helps. :smiley:

Yep, second audio is heavily distorted laught. I mean, old version seem to work fine so I will just stuck to it to make earrapes.

I think it’s some imputing/exporting issues with the latest LAME version that causes this to happen. I actually meant I don’t want clipping. I want perhaps distortion to make silly earrapes, but again, I want original audio to be recognizable. And newest version also adds some extra peaks to louder parts, even if not whole file is basically 0db, if it gets there even for a short period it makes distortion which is also unwanted.

So I have been trying to learn a little about earrapes and making them within Audacity. I believe the internal floating-point representation within Audacity may be working against you.

When you are creating these earrapes, let me suggest that you try changing Audacity’s internal representation from floating point to 24-bit PCM. You can do this easily for an individual track by clicking on the down-arrow in the Track Control Panel, then selecting Format, then 24-bit PCM. You can also change the default format for Audacity via Edit > Preferences > Quality > Default Sample Format.

This way, there will be no hidden audio above 0dB and you will have WYSIWYG, and audio rendered this way (via WAV or MP3, for example) should play the same in virtually any audio player.

If you ever need to return to regular audio processing, please remember to restore floating point when you do. :slight_smile:

I hope this helps. :smiley:

Unfortunately it didn’t change anything for me. I tried exporting file to mp3 with 24-bit setting, but it was white noise in audacity again.

Yes, I think you are correct, though there was a different problem with the older version of LAME.

With LAME 3.100, if the level goes above +10 dB (that’s more than 3 x higher than the maximum “legal” signal level), the import is corrupted.
I’m not sure if I’d call this a “bug” since it only occurs when the signal level is far higher than it should ever be for normal audio. Nevertheless I’ll log it as an “issue”.

With the earlier LAME 3.99r, the conversion was still wrong when the signal is massively high (in a different way), though I can’t bothered to investigate further as it is no longer relevant. :wink:

Some tracks does have -0db peaks and it’s made for contrast even in normal songs, also for some youtube audios where people might shout to micro or get really close to it this should work with any older audacity version