Normalization / Volume acting very strange

Win 10
Audacity 3.1.2

The normalization / volume effects are acting weird in one of my projects. Turns out that while I was typing this, I seem to have found the issue.

Problem / solution: I’m working on a mono track that is not really mono, but one half of a split stereo track with the pan manually reset to center. This seems to be causing the trouble. I can mix it down into a true mono and the problem is solved. So don’t work with fake mono, I guess…

Here’s my original post anyway, maybe it’s still worthy of a ticket :slight_smile:

I have plenty of headroom, the master meter doesn’t show any clipping, and “find clipping” detects no results.
Yet when i open the gain effect it shows a negative value, which normally indicates clipping (checking / uncheckng the box to allow clipping doesn’t make a difference)
whole project - no headroom.JPG
When i check individual clips, most of them show a realistic amount of headroom, except for three of them, which show either unrealistically low headroom or a negative value (attached examples 01-03).

Normalization isn’t working as it should either. When applied to the “unbroken” clips (the ones with realistic headroom values) the audio gets louder but still not to my chosen normalization level (-1). In order to reach -1 peak I need to repeat normalization a couple of times.

When applied to the broken clips, normalization does the opposite. It reduces the audio level and keeps reducing if I repeat the effect…
individual clip - ex 03.JPG
individual clip - ex 02.JPG
individual clip - ex 01.JPG

That sounds very peculiar.

If you copy one of the “bad” clips to a new project, then save the new project (with a new name), does the new project have the same problem?

Had to recreate the problem cause i didn’t save the buggy one before…

Copying bad clips into a new project solves the problem now. The gain effect shows me the correct headroom and normalizing works in one go as it should. And I just realized that when I delete all the clips except the bad one from the original project, the problem also disappears… I have no idea what’s going on anymore :slight_smile: Want to have a look at the aup?

Edit: I just closed and reopened the project and guess what, the bad clip is no longer bad…?!?

Can you provide precise instructions so that I can reproduce the problem here?

I’m guessing that it’s a huge file, so I’d rather create a minimal example here if that is possible.

Second best would be if you could create a reasonably small project that has the problem - however, if the problem disappears after saving, then I guess that might not be possible.

I was able to recreate it like this:

Import stereo file (mp3 in my case)
Split stereo (NOT split into mono)
Delete one of the two channels (I deleted the right channel)
Set the panning of the remaining track to Center
Randomly slice up the audio into a couple of clips until one of the gives you negative headroom value in the gain effect when it’s clearly not clipping

Thanks, hope it works

Randomly slice up the audio

How are you doing that?

Effect > Amplify, Effect > Normalize, and Effect > Loudness Normalization Only work once as long as you don’t change the work. If they continuously change the work, then something is reporting the wrong error, or interfering with error reporting.

What else do you have running on the machine?

What was Audacity doing just before you experienced this problem? Are you editing multiple shows?

Can you make it break after you clean shutdown Windows? Shift+Shutdown > Wait > Start. Then run Audacity by itself.


That’s not happening for me.

Could the problem be specific to that MP3?

Hey, sorry for the late reply…

Unfortunately the problem is not only with one specific mp3… it happened again with other files in the last couple of days.
The only thing all the files have in common as far as I can tell is that they were all recorded with a Zoom H1 mic (different mics, same model)
and then mixed down from stereo to mono (both via “split to mono” + delete one side + mixdown into new mono track and the “stereo to mono” macro). Unfortunately I don’t have time to do any further testing right now…

with a Zoom H1 mic

H1 or H1n? I think it was the H1 that had battery problems. My H1n seems to work OK. Yes, it’s a stereo device and I think it’s stuck like that. Because of the stereo microphone configuration, I suspect I might mix down to mono instead of splitting and deleting. That way you will get the expected cardioid response pattern and not an off-center blob.

the “stereo to mono” macro

What stereo to mono macro? Tracks > Mix > Mixdown is a standard tool.


No battery problems with my H1, but I did have a problem with an old flash card which caused minor corruption in the recorded file.
@ radioactive , if you’re recording to the flash card, it may be worth trying another flash card.

It’s a H1.

In my macro window there’s a “stereo to mono” entry (i think it’s there by default?)
and then there’s the Track > Mix > Mixdown option.

I assume those are just two ways to do the exact same thing?

I will try to switch memory cards and try the other suggestions you made as soon as I find the time.