Noise while recording a cassette via USB

I am using Windows 7, with the newest version of Audacity. I purchased a USB cassette to transfer my cassettes to my computer. I followed directions to setup my cassette player. I pressed record in audacity and play on my cassette, it started to record in audacity and I could hear the music clearly. I then realized I wasn’t at the beginning of the cassette and stopped the recording and re-wound my cassette, pressed record and play on my cassette, and got nothing but a screeching noise. Seeking help online, I restarted audacity, transport - rescan audio devices several times. This did not solve the problem and I can find no further instruction on what is wrong.

Can some please help?

Please, see the pink panel at the top of the page and always give us all three Audacity version numbers. There are bogus versions of Audacity out there not made by us.

Try reconnecting the cable (make sure it is tight both ends) or change the USB cable. The cables that come with USB cassette players are quite often defective.



I have tired two other USB cords that I know work. I am still getting the screeching noise and instead of waves jumping up and down, there is a solid blue pattern. Any other suggestions?


Are you sure you still have Audacity set to record from the USB Audio CODEC?

Try doing without Transport > Software Playthrough.

Try rebooting the computer.

If it won’t resolve itself, you might be able to connect from the headphones out of the cassette player to the computer. It should work fine if the computer has a stereo line-in separate from the mic input. Choose the correct line-in or mic input in Audacity. If you use the mic input, turn the Audacity recording slider as low as you can.


In audacity on the device toolbar, I have selected the following: MME - Microphone (high definition) audio (there is no option listed for USB) - 2(stereo)Record - Microsoft sound mapper output. In Windows, when I click on my speaker icon “recording devices” there is no option for USB only microphone.

I took off the “software playthrough”. I got a wave pattern that looked normal, but when I played it back in an mp3 file I created, there was no sound. I tried connecting from headphones, and doesn’t work either.

What I don’t under, is that everything worked the first time I tried it. Is the situation hopeless?


Then that is what you have to fix (somehow). If Windows does not see the USB Audio CODEC for the cassette player, Audacity cannot record from it. With Audacity set to the Sound Mapper input, you are recording whatever is the default Windows recording device, perhaps the internal microphone.

You need the correct cable to do that. What audio inputs does the computer have? If there is only one audio input, does that input also function as an output that you connect speakers or headphones to?

Whatever non-USB input you connect to, you should restart Audacity (or do Transport > Rescan Audio Devices) then choose that input in Audacity’s Device Toolbar. Sound Mapper - Input will not work unless you also change the Windows Default recording device to that input.


I read in “Recording with USB turntable or USB cassette decks”, page 3 under “Devices”, "Windows Vista and later call most USB external devices “microphones”. I have Sound Mapper set to output in the speaker section of Device Toolbar.

I don’t have a lot of computer knowledge, so I don’t know how to check what audio inputs my computer has.

Still how do you explain that the first time I used the cassette via Audacity it worked?

Thanks Terrie

That is only by way of explanation that the name of the USB cassette recording device could appear in Audacity and Windows as “USB microphone” even though it is not a microphone.

You know what name your USB device appears as, so you can disregard the text you quoted.

Don’t, because if your USB cassette player was working, setting the Device Toolbar playback device to Sound Mapper - Output would probably mean you would have no playback sound in Audacity.

Do what we suggest and do not choose Sound Mapper - Input or Sound Mapper - Output in Audacity. Choose the actual Speakers or Headphones for playback device.

If you want to connect your cassette player to a non-USB audio input on your computer, restart Audacity then choose the actual name of the non-USB audio input you connected to.

If you only have a microphone input on your computer, that input will be called “External Microphone” in Audacity.

If you have two audio inputs (one for microphone and one for strong stereo signals), the input for strong signals will be called “Line In”.

Have you tried looking at your computer’s manual?

If not, look at the sides and back/front of the computer. Do you see a 1/4 inch hole that has a little microphone symbol by it, and next to that, a 1/4 inch hole that has a headphones symbol by it?

If not, what do you see? If the holes are coloured, tell us what the colours are. A green hole is always only an output, for connecting speakers or headphones.

A pink hole is always only a microphone.

A blue hole is always only a line-in. If you have a blue hole, that is the hole to connect the cassette player headphones to.

Do you have a cable that fits into the headphones on the cassette player, and the other end fits into a 1/4 inch hole in the computer?

Audacity does not make cassette players or any other hardware.

If you are sure the USB recording part of the device has failed, and the device is still under warranty, ask your supplier for a replacement.



I have a laptop with two holes in front, one for mic and one for earphone. two USB port on the right side.

Feeling totally overwhelmed on how to figure out my problem, I resigning myself to go to my computer guy at $75/hr. But thought I would try one last thing first. I removed Audacity from my computer, and using the cd that came with my cassette reloading Audacity. Then plugged my cassette back to computer, to my utter joy, in the device toolbar by the mic symbol, I found "Microphone Array (USB PnP audio). I tried to record, but no sound. Then I went into my sound on computer and instead of just a microphone symbol I saw the USB info. I can hear and record my music.

Thanks so much for your time and patience.

I’m glad it seems to be working now.

So do you have now an older version of Audacity (earlier than the current 2.1.1)? Reinstalling Audacity in itself never changes its core settings, unless you enable the “Reset Preferences” box in the installer.

If the USB device fails to be recognised again, follow the procedure in the green box “Detecting USB and Firewire devices” on this page:

So, if you ever need to do that, the mic hole would show up as “External microphone” in Audacity’s Device Toolbar, and you would choose that as recording device.

This assumes the external mic was enabled in Windows Sound and that the cassette player headphones were connected to it.



The audacity version on the cd enclosed with my cassette is 2.0.3. When I had trouble from the start I updated to 2.1.1 thinking that would help. Now that I reinstalled the 2.0.3, I don’t dare do anything different or rock the boat.

I so appreciate everything you have helped me with and I am keeping all your responses and information you gave in case I have further problems.

Thanks for being there,