Noise removed in Audacity but not in exported file

I removed noise of an audio file in Audacity 2.0 (dmg) for Mac (10.7.3) by using noise analysis, selecting everything and applying noise removal. Success!

Then I used File > Export to save out a WAV file with standard settings (I changed nothing).

When listening to the file, I hear noise, but inside Audacity, I hear no noise.

What could be the reason?

Thanks a lot!

1 Like

How much noise are you talking about?
What is the peak level of the audio in the track?
Did you Normalize the track before Exporting?
Are you absolutely sure that you are listening to the exported file and not to the original (unprocessed) file? (not wanting to be patronising, but need to check).
What is the file name of the original audio file and what is the file name of the exported file?

Thanks a lot for your quick reply!
I don’t know how to answer the first question of how much noise, but it’s easy to hear.

No I didn’t normalize the track before exporting.

I didn’t overwrite the original. The new file is at a different location and has whatever name I gave it obviously.
It sounds slightly different from the original but also has noise, while in Audacity I hear absolutely no noise after noise removal. Do the standard export settings of a WAV file introduce noise?

I don’t know how to answer the first question of how much noise, but it’s easy to hear.

Look at the bouncing green sound meters and tell us where they bounce during the show and where they bounce during the noise. You may need to expand the meter size to see any detail.

This is a normal show. You can make the meters bigger by grabbing the right-hand edge and pulling sideways. The other tools will get out of the way.

We have had instances where people produce a show that’s very low volume and call that normal. If they do, many of the normal housekeeping tricks in Audacity will become objectionable distortion.


Another way to determine the levels in your recording is this:

  1. Select a noise-only portion of the track (the portion you selected before doing Effect > Noise Removal then clicking the “Get Noise Profile” button)
    Do Effect > Amplify
    Don’t click the OK button, instead write down the number in the “Amplification (dB)” box, then click “Cancel”
  2. Select the entire track
    Do Effect > Amplify
    Don’t click the OK button, instead write down the number in the “Amplification (dB)” box, then click “Cancel”

Tell us those two numbers.

– Bill

Here are the numbers (dB) of the Amplify dialog box:

Noise Part: 47.7

Entire Track: 15.9

OK, the signal to noise ratio of your file is pretty bad to begin with - about 32 dB.

When you say you had success with the Noise Removal effect, was the noise completely eliminated? It’s hard to do that with noise levels that high without causing artefacts in the remaining audio.

What are your settings in Audacity > Preferences > Quality? All of them. I wondering if you’re hearing the dither noise in the exported file, although that seems unlikely.
[Admittedly grasping at straws here :frowning: ]

– Bill

Well the peak level for the entire track is a bit low, but that noise level is very high.

By default Audacity does add a tiny bit of noise when exporting a 16 bit file, but I mean really tiny (around -90 dB RMS). This “noise” is dither noise, and is intentional as it reduces the “noise” from quantize errors. The noise level that you are describing is way higher than dither noise.

Could you describe in more detail what you are doing, what equipment you are using, what buttons you are pressing… lots of details. (at present the problem is a mystery but I can’t picture what you’re doing).

I strictly follow a German tutorial video, here are the steps.

i mark part of the file with just noise.

Effect > Noise Removal > Get Noise Profile

Select everything (Cmd+A)

Effect > Noise Removal > OK

I play the file, no noise. I think I’m done and can just export the file.

I export the file and change nothing (just noticed it’s not possible to change the options anyway)

Result: the exported file is noisy.

I just looked for a simple way to denoise it, if it’s complicated I’ll just not do it, I don’t want to learn the whole application just to remove noise.

I didn’t change any preferences.

That sounds just right (though tweaking some of the settings in the Noise Removal effect may improve the results, but we can come back to that later).

Could you give a step-by-step breakdown of exactly how you are doing that.
It sounds like you are doing everything right, but there must be something not quite right because the exported file should not sound different from the track in Audacity.

I expected it to sound the same.

I just go to File > Export, leave the setting to WAV and choose a place and filename.

If you import the processed file back into Audacity and play it, how does it sound?
What program were you using to play the exported file?
Were you listening with the same headphones/speakers?

I also had an issue like this, removed noise in audacity exported as WAV but still has the noise on the exported file. But when I exported it in mp3 the noise was removed.