Noise removal doing the opposite of what it should

I’ve just recorded a 10 second clip, the first 5 seconds are room noise and the rest is just me saying testing and stuff.

I select those first five seconds, effects < noise removal < get noise profile

Then I CTRL+A to select everything, and click “repeat noise removal”

It worked when I did it 15 minutes ago, where the background noise was gone, and my voice was nice and clear. Something broke since then I guess, because now it leaves the background noise and makes only my voice suppressed.

Any idea where I went wrong or what is messing up?

I don’t think I would have clicked Repeat Noise Removal. That would have repeated Get Profile. So get the profile again and this time select all (or click above the MUTE button) and Effect < Noise Removal and this time select your removal parameters > OK.


There’s also a clicky that reverses Noise Removal. It’s an “Isolate” button.


Actually Koz the methodology that Polaroidon is using works fine - I do it all the time - using the Repeat Noise Removal after the noise profile grab followed by a select all works fine.

So I’m puzzled as to why subsequent uses of NR fail for Polaroidon: are you sure that you haven’t somehow reset the noise profile. Can you tell us a little more about your workflow and what you do with Audacity between the first NR that worked and the second that failed. :confused: