Noise Removal Does Not Work

I’ve encountered a problem with Audacity that I was hoping someone could help me with. So I’ve been going back and mastering some of my recordings. A lot of them have noise at the end, which I am able to get rid of using the noise removal tool. But when I export the file and go back and play it, the noise is still there clear as day. I don’t know if this is a bug or what, but any suggestions would be appreciated.

How much and what sort of noise are you talking about?
What format are you exporting as?
Perhaps you could post a short sample to illustrate (see here for how to send audio samples:

It’s just regular white noise at the end of the recording. I mean I can get rid of it with the noise removal, but it always reappears when I play the file. I export as 16 bit wav.

Could you import the file back into Audacity and select just the noise from the end of the file. Ensure that it is only the noise and does not include any of the real audio.
Go to the Effect menu and select “Amplify” - do not press the “OK” button.
What are the settings in Audacity?
(Press the Cancel button).

Okay I did that and this is what it says:
Amplification (db): 50.0
New Peak Amplitude (db): -20.3

That means that the noise has a peak level of -70 dB, so it is probably normal “dither” noise. If you can hear that clearly then the level of the normal audio is too low, meaning that you need to have the playback volume turned up loud to be at a “normal” listening level, meaning that the dither noise becomes noticeable.

Before exporting, if you use the “Amplify” effect with the default settings it will bring the peak level of the track up to 0 dB and the dither noise will be 70 dB (a lot) below that and should be virtually unnoticeable unless you have the volume turned up to an ear-bleeding level (not recommended).

Dither noise is generally a good thing (when applied only during the final export) as it can extend the undistorted dynamic range of 16 bit audio beyond 100 dB whereas without dither the dynamic range is 96 dB with considerable distortion at the quiet end of the scale, giving an undistorted dynamic range of less than 70 dB. So the trade of for the -70 dB dither noise is that eliminates distortion at this level and extends undistorted reproduction by over 30 dB.

Ah I see! Well thanks for explaining that. So the “dither” noise is actually created when I export my song? And there’s a not a way to get rid of it?

Open the Quality Preferences (bottom of the Edit Menu, or the Audacity Menu on Mac) then under “High-Quality Conversion”, set “Dither” to “None”. As Steve said there is a chance this will increase distortion in quiet music (because the dither noise is intended to smother it).


Not just “a chance”. Unless the audio is unprocessed 16 bit audio data it’s a certainty that there will be increased distortion when converted to 16 bit if dither is disabled. If the peak audio level is close to 0 dB then dither noise will be extremely quiet. If properly applied dither noise is easily noticeable, then it is probably because the overall audio level is too low.

If you need absolute silence between tracks, then a better way to achieve this is to trim the track in Audacity so as to remove all leading and trailing silence, then use your CD burning software to insert a “gap” (pause) between tracks (assuming the final format is a CD).