Noise Reduction: Unable to correct Validation Error Message [SOLVED]

OS: Windows 10
Mic: Procaster
Audio Interface: Focusrite Scarlett
Audacity Ver: 3.0.2

I have just updated from 2.4.2 to 3.0.2 and have identified an issue with the Noise Reduction effect.

I am going through the normal procedure of selecting a small sample of audio at the start of my track, selecting Noise Reduction and Get Noise Profile.
I then get an error message:
‘Value Not in Range 0 to 24’

I have made no changes to my recording process. I am recording directly into Audacity.
I have tried altering the noise reduction and sensitivity settings to no avail. I have even tried re-installing and have read all I can on the Forum and Wiki.

This is something i have not experienced before on the earlier version of Audacity and would greatly appreciate some help as I have a lot to edit in the next few days.
Thank You

Ensure that “Sensitivity” is set between 1 and 24. The default value (recommended) is 6.

Default settings are: 12, 6, 3, reduce=selected.
See: Noise Reduction - Audacity Manual

thanks for the quick response Steve,

yes, I have been using the default settings, with
NR = 12
S = 6
FS = 3

this makes no difference.
Is it possible there is a bug in the noise profile generator?
Has anyone else noticed this problem?
is there a workaround, such as using a low-pass filter instead?

What language are you using?
Have you modified the Windows setting for number formats (decimal separator)?

have it set to english. (am in the UK)
have not made any alterations to number formats - not sure i know how - but I will find out and check.

Hi Steve,

Youre a STAR! :ugeek:

Im set to english (am in the UK)
Found my way into the regional number settings, and looks like it was set to European, with full-stops for decimals.
have re-started Audacity and it looks like its now working.

Thank you for the help, i was relly getting worried I wouldnt finish my project.

You’re welcome.
I’ll close this topic as “solved”.

I have the same problem and realized that changing my number settings to Metric caused the problem, but now I don’t know how the settings should be. :woozy_face: Commas or full stops?

Resetting my number format setting to default helped and solved the issue. Thanks. :slight_smile: