noise reduction issues

Noise reduction is causing my S’s to sound hissy. Anybody have a solution? Help me out! Thanks.

There’s only one complete solution - make your recordings with less background noise and use less (or no) noise reduction.

As a workaround for your current recordings, you could try using the Equalization effect to reduce the level of the “S’s”, or you could try a “De-esser” plug-in (such as the “SpitFish De-Esser” -

I also forgot to mention that I’ve always had the same amount of BG noise in all my recordings, and it only has the hissy S’s pretty much whenever it feels like it. Could it have something to do with the wetness? Or should I just try to use a lower dB setting?

For tweaking the Noise Reduction effect, the first thing I’d try is reducing the “Noise reduction (dB)” setting.

What settings are you currently using?

You could also try sightly increasing the “Sensitivity” control.
(The default settings are shown in the manual here: