Noise in recorded clip from stereo mix of VLC playback-FIXED


The answer to my problem is probably somewhere here in the forum, but I did not find it.

I am using Window 7 64 bit and audacity 2.0.5.

When I record from stereo mix as an input device during VlC playback, the recorded clip has a noise in the background. However, when I do the same but from Windows Media player, the result is fine without any noise.

I attached sample with the noise:

Are you looking for a solution or an explanation?
I don’t know what the explanation is - the recording from VLC is wrong.

Two solutions come to mind:

  1. Record from Windows Media Player rather than VLC.
  2. VLC has a feature that allows you to write the output directly to a file rather than to the sound card (see the VLC documentation for how to do that

Thanks for the reply.
I would like to know the reason for the noise and to find a solution that will let me the get a clip without the noise. Of course for the situation I described above I can just use WMP instead of VLC. But the same noise I get also when I produce music with another (unfamiliar) software and record the output with audacity. I suppose the reason for the noise is the same. I mentioned VLC just because it is well known. I look at the FAQ and tried a few procedures but without success.

What exactly are you playing through WMP or VLC?

Network audio stream (radio show).

I forgot to mention:

  1. After a while (10-30 minutes) of recording, the noise disappears.

  2. I did not have this problem before. It is only recently (did not do any major changes).

  3. I tried different levels of volume recording/playback, all had the same noise with the same volume level.


I succeeded to solve the problem. I uninstalled Audacity completely and removed any traces of the program from the PC. Made a fresh Install and now everything is fine.

Just re-installation/update of the program did not help.

Thank you for this great program!

It never usually does, unless you select the installation option to “Reset Preferences”- what gets left behind from the previous installations is your .cfg file *(where your preferences are stored.

Have a look at this page in the manual:


And how did you do that and what did you remove?

The only likely explanation that could be anything to do with Audacity is that you previously had Audacity 1.2 which stores its settings in the Windows Registry, then removed the registry settings. If you had not “Reset Preferences” in the 2.0.5 installer then Audacity would have still been using the 1.2 settings where they had an equivalent in 2.0.5.

DISCLAIMER: Users should not manually edit the Windows Registry because it can harm their computer.


I reformatted my computer a few month a go. So there isn’t any chance for registry files from 1.2.

What I did is:
1.Uninstall with Revo uninstaller.
2. With Ccleaner, checked for Audacity registry files and removed (ONLY) those files.
3. Remove audacity folder from ‘program files folder’ and from ‘user forder’.

Thanks for clarifying. Step “3” (given there are no 1.2 registry settings) would do the same as “Reset Preferences” in the installer. So your cleaning might have an effect on audio recording if and only if you had not already “Reset Preferences” in the installer.

None of the registry entries written by the 2.0.5 installer (or by Windows) should have anything to do with audio. The 2.0.5 program itself doesn’t write to the registry.

So I would still say that reinstalling Audacity with “Reset Preferences” checked (ticked) is all that should be necessary to attempt to solve a purely audio problem. Certainly that is a much easier option.