Noise Gate Not Working

I downloaded the Nyquist Noise Gate and used it on the previous episode of my podcast successfully. Today I got the next episode ready for editing and the Noise Gate isn’t working at all. Half the time it takes like 3 minutes and then nothing has changed, half the time it takes like 3 minutes and then tells me it can’t find a file on “C:”

I tried re-downloading it and still nothing. Any ideas?

What’s the full and exact error message, and when exactly does it occur?

tells me it can’t find a file on “C:”

That’s the name of your main drive. What did you use as a filename? It’s a bad idea to use punctuation marks in filenames. Today is 2018-03-21, not 3/21/18.

underscore and -dash- are OK.


I I know what C: is, I put the quotation marks because I’ve had it autocorrect to an emoji before if I don’t. I don’t use punctuation in the filenames either.

“Audacity failed to read a file from C:.”

If the gate threshold is set too low then the gate won’t change anything.
Viewing the waveform with dB scale makes it easier to see the noise level …
Waveform on dB scale , -48dB (default) is too low in this case.png
In this case the default gate threshold of -48dB is too low, use -44dB instead.

To avoid that, use the “Code” tag button (in the set of buttons above the message composing box). The “code” tags present literal characters (and preserve spaces):

Audacity failed to read a file from C:.

I don’t recognise that as an Audacity error, and “C:.” is not a valid file location.
Perhaps you could post a screenshot of the error dialog (including the complete dialog window).

Screenshot (87).png

I don’t think the problem has anything to do with “Noise Gate”.
Try applying the “Amplify” effect to the track - do you get the same error?
If no error with “Amplify”, try the “Low Pass Filter” effect.