noise gate error "nyquist returned the value: [attack time]"

I’m trying to use this Noise Gate:
but whenever I load it up with Nyquist prompt and set my parameters, it always will return the error message of “nyquist returned the value: [attack time]” without making any change to my audio. Here are some pictures to illustrate:

Would anyone know what’s happening here or what I’m doing incorrectly?

Try clicking the “Debug” button instead of the “OK” button. That will cause a debug window to open after the effect runs. Copy and paste any information shown in the debug window into your reply.

Please also tell us which version of Audacity you are using (the version number is shown in “Help menu > About Audacity”)

Pressing the Debug button does pop up a window after it gives the same value return as before, but the window is completely empty.
I’m using version 2.2.2 of Audacity.

The noise gate works perfectly for me. What do I need to do to reproduce the problem? (talk me through, step by step, what you are doing so that I can do exactly the same).

I have an .ogg file sent to me from someone else which was recorded through audacity, though I don’t know which version of Audacity he used. I first open up Audacity, then use ctrl+O to open the .ogg. I then select the whole track, go to Effect > Nyquist Prompt > Load, and select the Noisegate.ny file I downloaded from the link I originally posted. Whether I then press “Debug” or “Run” it then brings me to the popup where I can set my parameters. I change nothing except the threshold, which I set to -36 dB.

As I’m typing this out, I’m stepping through the process once again, and this time pressing Ok gave me a slightly different outcome. Instead of returning the attack time value, it hung for a bit before giving me this error:
I tried to recreate this twice more, this time without reloading the code and instead using what was already loaded, but Audacity just returned the attack time value immediately as it had done before. If I reload the code again, then pressing Ok on both subsequent prompts will reliably bring up this error, and again, only after it hangs for around 45 seconds.
Reloading the code and this time pressing Debug on both prompts instead of Ok on the final one will bring this up:
which is nearly the same as before, except there’s an actual textbox inside it. Still blank, though.

Does the imported file play correctly?
What happens if you try applying some other effect instead of the Noise Gate?

Yes, the imported file plays just fine, and I just tried applying noise reduction, compression, and normalization to it without any issue.

Please try another of the effects from the lower part of the Effect menu (below the dividing line), for example, the High Pass Filter.

How long is the audio track?

Applied both High Pass Filter and Tremolo to test, and they went through just fine. Track is 1h27m17.217s.

That is probably the problem. Try running the effect on shorter sections of the track, for example, apply to the first 30 minutes, then the next 30 minutes and then the final 27 minutes.

Wow, that was absolutely it. I don’t know how you got that from those error messages, but thank you very much.

It was the track length that gave the clue.
On 32-bit machines, the maximum amount of RAM that can be accessed by an application is about 2 GB. The Noise Gate is a Nyquist plug-in, and Nyquist is 32-bit, so this limitation may also apply on some 64-bit machines.

The Noise Gate is a two pass effect, first it gets the amplitude envelope, then it applies a variable amount of gain. Nyquist plug-ins can only read the audio data once, so the entire selection has to be retained in memory.

Audacity works internally in 32-bit float format, and 1hour 27 mins is more than 2 GB, which is the cause of the problem.


I’m using Audacity 2.2.2 on Windows 10. The same “noisegate.ny” plugin fails for me. I’m editing a 2-minute mono track, so length is (hopefully) not an issue here. My settings are: Gate frequencies above: 0.00, Level Reduction: -15.0 db, Gate Threshold: -47.00, Attack/Decay: 50.0. When I press the “Debug” button, I get the following message: “Warning: cannot go back in time to 0, sound came from (FORCE-SRATE S%RATE (ABS-ENV (S-REST LOOKAHEAD)))”. No gating happens when I give it a normal OK. Please let me know what other information you might need to understand this problem.

Thanks in Advance.