Noise Gate Enabled But Not Showing [Win 10 - Aud 2.3.2]

Hello Everyone,

My issue is that I downloaded Noise Gate and, although it is showing as “Enabled” on the list of plug-ins under the “Add / Remove Plug-ins…” section, it doesn’t show under “Effects” and thus seems unavailable to use.

I’ve tried…
restarting Audacity
disabling and re-enabling the plug-in
restarting my PC
running Audacity as admin

Windows 10
Audacity 2.3.2

Thank you for any help you can offer

Effects has a light gray dividing line roughly half-way down. Noise Gate is below the line.



I should have specified before that I slowly and thoroughly “walked” down the list multiple times just to be sure that I didn’t simply miss the option. I just did so again several times and have been after each attempt to make it appear. I was so desperate I even slowly checked the list of “Tools”, “Analyze”, and “Generate”. I even kept looking for any indicator that I could scroll down further. There is no arrow or anything like that because I don’t have enough plugins for that. My grey bar is towards the bottom of my list.

Thank you for the attempt.

Did you get Noise Gate from here?

And you installed it like this…

Then we should wait for a Windows elf—which I’m not.


Yes, to your first question.

Yes and No, to the second. I installed it manually but it was to the correct folder. Or at least I thought it was. Just tried installing using the installer of Audacity and it sent the plug-in to a different location. The result is exactly the same however. Shows as “Enabled” doesn’t show in the “Effects” menu.

Thanks again for the effort.

Close Audacity, then go to:
and delete the files:

Restart Audacity, and enable the Noise Gate plug-in.

This doesn’t appear to resolve the issue. Still not showing after trying these instructions multiple times. Removing and then re-installing the plugin then following these steps. Tried doing the same with another Nyquist effect called Pop Mute and I am having the same problem there as well.

I have two locations for plugins:
C:\Program Files(x86)\Audacity\plug-ins

And I’ve tried one then the other and then tried both of them at the same time.

They continue to show as Enabled even after I close Audacity and restart it but do not show in my Effects menu.

Tried doing the same with another Nyquist effect called Pop Mute and I am having the same problem there as well.

Have you ever gotten any plugins to work?


I’ve only tried to download 2 so far if you’re asking about plug-ins that don’t come with Audacity.

Other Effects and plug-ins show and work fine. But no, I have not been able to download/install a plug-in and have it show in the drop down menu for use.

Do you have “High Pass Filter” and “Low Pass Filter” in the Effect menu?

Yes, I can see both of those.

Does the plug-ins manager say that Noise Gate is enabled?

I’m a little confused by the question. Is there another place where plug-ins can show as Enabled other than the one(s) I mentioned called “Plug-Ins Manager”? If there is a section called Plug-Ins Manager that isn’t “Add / Remove Plug-ins…”, I don’t see it.

I see that your original post says:
“although it is showing as “Enabled” on the list of plug-ins under the “Add / Remove Plug-ins…” section”

I want to check that that is actually the case. If I take everything you have said on face value, then your computer is doing the impossible. Somewhere we are missing something.

If you open the “Manage Plug-ins” dialog now (, and select the “Enabled” radio button, is “Noise Gate” in the list of enabled plug-ins?

Lol, I understand how unbelievable this all sounds but yes, the title of the topic actually is the case. I also believe I mentioned that this is true even if I close and restart Audacity. Meaning it shows as Enabled but doesn’t appear on the list. Close Audacity, restart Audacity, it still shows as Enabled, still doesn’t appear on the list.

Before I created the topic, I checked more times than I can count. Got some sleep, tried again the next day and so forth. I’ve been trying and Googling this for about 3 or 4 days before I created the topic.

In the list of enabled plug-ins, what does it say is the “Path” to the Noise Gate plug-in? (you may need to expand the dialog to see the full path)

This is better than daytime television. I’m making popcorn.


Launch Audacity and generate, record or import some audio.
With the track selected, run this command in the Nyquist Prompt:

(format nil "~s" (aud-do "NoiseGate"))

What happens?

C:\Program Files(x86)\Audacity\plug-ins\noisegate.ny

I suppose it’s… good that one of us is enjoying this.

I’m not sure if I did this right at all, but I entered it exactly as you posted it, including the parenthesis, and got this:
(" " . T)

I’m also going to attempt to provide some images here:

Add / Remove Plug-ins… Section –

Effects –

Nyquist Prompt Response –

And if you scroll down this list a bit further?