Noise added to silence when exporting [SOLVED]


I’m not sure if the following is a bug or just how Audacity works.

After creating a new mono audio track (Tracks → Add New → Mono Track) and generating 15 or so seconds of silence (Generate → Silence… → 15.000s → OK Button), we notice the following:

However, if we then export the mono audio track (File → Export Audio → 16-bit PCM WAV) and then re-import the saved audio file, we notice the following:

So my question is, where does the digital noise (if you want to call it that) come from?

Please keep in mind that I understand full well that no one will be able to hear this digital noise, but I’m planning on using Audacity for a scientific project (rather than an audio mixing session) and need to understand whether the digital noise is a side effect of the PCM file format or a bug in Audacity.

Thank you,

I’m planning on using Audacity for a scientific project

That’s the phrase that pays right there. Audacity does things that are theatrically desirable but drive scientists nuts.

For one thing, it runs internally at 32-bit Floating, not 16-bit, so it has to convert bit depths going in and coming back out. It adds dither or a tiny bit of “noise” to the show in order to keep digital conversion errors (coming back down) from lining up and becoming audible.

You can turn that off in preferences (Quality), but if you do, any changes you make to the show may exhibit odd distortions you may not like.


See here for more information about “dither”:

For “scientific” work, it would be best to work entirely in 32-bit float format (Single-precision floating-point format).
You can export as 32-bit float WAV by selecting “Other uncompressed files” as the file type when exporting, then setting the options to “WAV” and “32-bit float”.
You can then leave the “Dither” preference at the default (“shaped”), which is the correct setting for normal audio work, but no dither will be applied when exporting because there is no reduction in bit-depth when exporting as 32-bit float.

Note that many other applications don’t support 32-bit float, so if you are using other software as well as Audacity, then you may need to export as 16-bit or 24-bit, in which case you will need to turn Dither off in Preferences if you don’t want the exported file to be dithered.

Exporting as a 32 bit WAV worked.

Thank you both for your help,