No Waveform, No Sound


I am running Audacity 2.02 on a Windows 7 Professional 64-bit operating system, and I am having the following problem, which started about a week ago for me.

I use Audacity to edit audio files (aiff and aiff converted to MP3) that I record myself on my iPhone. Usually, I just drag the file into audacity and rock-n-roll. Now, however, I drag them in or import them (file > import > audio), and when it imports them, there is no waveform, just a straight line, and no sound when I play them, although the length of the playback section is consistent with the length of the audio file. This only happens when I select “make a copy of the files before editing.” If I select “read the files directly from the original,” then the audio does play back, but instead of seeing a waveform, I see a series of diagonal blue lines, which makes editing much more difficult, if not near-impossible to get right.

Any input on this would be greatly appreciated. I don’t know this program very well, so if you could be clear and specific in your suggestions, that would help.

Thanks so much,


The diagonal lines are normal when importing uncompressed audio with “read the files directly from the original” selected, but after a few moments those lines should start to disappear and be replaced by the actual waveform. I presume that is not happening even if you leave the computer for several minutes?

Do you have any old audio files that previously worked with Audacity? If you have, do they still work?

Thanks for responding.

No, the diagonal lines do not go away, no longer how long I leave it for.

And I tried importing old files which I edited a few months ago, and the same thing happens–no waveform, no sound.

Any ideas?

Have you changed your Audacity temporary directory to somewhere you don’t have permission to write to, or to a drive that is failing? Please check at Edit > Preferences: Directories.

If changing the temporary directory does not help, can you please (after importing a file) click Help > Show Log… then Log > Save… and attach the log here (see for how to attach files).


That did it!

I changed the temp directory to a folder I created on my desktop, and presto, I’ve got waveforms and sound. Thank you so much for your help. I really appreciate it, although I don’t know why that problem happened in the first place. Hmmmmm–I did install some new antivirus software. Maybe that was it. Thanks again, though, and God bless.