no sysdefault in playback device menu

Ubuntu 13.10
Audacity 2.0.3

Sometimes when I load Audacity there is only 4 options in the device menu for playback:

  • HDA Intel PCH: HDMI 0 (hw:0,3)
  • hdmi
  • pulse
  • default

When this happens playback doesn’t work. The first 2 options give silent playback, the second 2 makes playback whiz through the audio at about 100x normal speed and produces just a crackling sound. If I press stop while it’s doing this Audacity crashes.

It used to be the case that if I closed Audacity and all programs that play sound, then reopened it then the device menu would be populated with more options including “sysdefault” which would work. But recently that hasn’t been happening - I only get the 4 options that don’t work now.

Try rebooting the computer to detect all device choices.

Check that the HDMI output has speakers connected to that output and that you have not muted the HDMI output in the system sound or PulseAudio Volume Control.

To fix the fast playback when choosing pulse or default, launch Audacity from a terminal with

env PULSE_LATENCY_MSEC=30 audacity

as per https://bugs.launchpad.net/ubuntu/+source/audacity/+bug/1246092 .


Gale

Thanks, that work-around for Pulse Audio works.