No sound when copying or when replaying in Audacity

I am using the latest version of Audacity, Windows 7, 64 bit. I have read and reread the Audacity instructions for first time copying. I am using a TaoTronics “Super USB Cassette Capture” tape player. Ultimately I want to copy some oral history tapes, but have tried learning this system using a commercial audio music tape. I have checked the box for listening as the tape is being copied, but can’t hear anything. Tried stopping the taping, and listening to Audacity from the beginning, but no sound. This is new to me, and I am probably overlooking something but haven’t figured it out and would appreciate some help. Thanks.

If you have lost all sound on your computer, see here in the Frequently Asked Questions:

The sound on my computer is working fine.

What do you have set as the output (playback) device in the Device Toolbar?
If you import a “known to be good” audio file into Audacity and play it, can you hear it?
Is there a visible waveform (wiggly blue shape) in the track that you record?

Under “preferences”, playback device is Realtek Digital Output. Under Recording Device, I see “no devices found.” My cassette player is connected via USB, but I don’t see any options for that in Audacity. I checked Amazon reviews, and found someone with the same problem with my cassette player where sometimes Audacity will recognize the device and sometimes not. Occasionally I’ve gotten a popup window: “Error while opening sound device. Please check the input device settings and the project sample rate.” I don’t see any way to do that. I’m going to send the device back to Amazon, and try something else!

Make sure that you connect the USB device before you open Audacity. The device has to be recognised by Windows before Audacity is able to see it,

It worked. I plugged in the device, opened Audacity. Did make sure sound was through the speakers, and was able to hear and view recording. A bit staticky, but will do. I also was able to make a CD.
I almost had the cassette player in the mail, but saw your post and decided to try one more time. Thanks for your help.