No Sound , No Waveform

I tried my first recording and did not succeed.
I have Linux mint 19.1
I connected through the USB slot in the computer a Blue Snowball Microphone
I then connected my Earphones
The Device toolbar says: Alsa Blue Snowball 1 mono Speaker Icon says Default
I clicked Start Monitoring and said a few words, it registered on the meter so that seems to work
I then clicked Record and said several words and then clicked Stop.
I then clicked Play and heard a Very , Very low playing of what I said through the earphones. Barely hearable.
I noticed the timeline expanded but there was No Waveform
I am a complete Novice
Can anyone tell me what I should do ?
Thanks for your time and effort

Have you tried setting the recording volume to louder?

The recording volume? How ?
If you mean the Slider by the Microphone icon,
is all the way to the right and does not move.

Ensure that the " three-position switch" switch is set for “cardioid capsule”, and ensure that you are talking in a reasonably loud voice (as if you are talking to someone in the same room) and the microphone is within 20 cm of your mouth (ideally with a pop shield between your mouth and the microphone). Ensure that the front of the mic is facing you.

There is no three position switch on my Blue Snowball Microphone. The Mike connects right into the computer usb slot.
Yes I am close to the microphone and it is facing me.
And I am speaking at a loud enough voice
I will try again to see if I can notice anything else

OK, I think I may have fixed my problem.
Remember, the problem was that when I recorded something, I could not hear what I was recording through the earphones and when I tried playing back what I recorded, I could just Barely hear it at a Very low sound.
And the other problem was that there was almost No Waveform. It was So small, just a Tiny bit away from 0.
Here is what I did:
I clicked on the Effects Menu and Clicked Amplify and then raised it. Then in the same box I Clicked Allow Clipping.
Now, I can hear what I am recording perfectly and when I play back, I can hear perfectly. Also, There is now a Waveform.

Hi – I’m having the same identical challenges that you had. I’m taking your advice and hopefully it works! Thanking you in advance.