no sound during recording [SOLVED]

OS 10.6.8 Audacity 2.1.2 Downloaded DMG. Stanton USB 90. I can record and export to my HD and then play it back in itunes with sound. I cannot get any sound whilst recording. I notice that the AUDIO I/O option is missing using a mac, and I’m wondering if that is the problem. The device settings are correct i.e. USB AUDIO CODEC. The Software Playthrough box is ticked. System prefs sound input is USB AUDIO CODEC and the output is at 'internal speakers.
In desperation, I have used different combinations trying to have some sound playing the LP. The moderators on a mac forum I use do not have a solution. Can anyone help? botise.

Audacity > Preferences > Recording: [X] Playthrough (both) > OK

I don’t think the Software Playthrough actually does anything. It may have in the past.


The Audio I/O section of Preferences is missing because it doesn’t exist in Audacity 2.x versions.

I suggest you read this section in the 2.1.2 Manual for further information: Recording with USB turntables or USB cassette decks.

As it says on that page, if Software Playthrough does not work on Mac, try LineIn from


The Linein option is for OS10.7.and higher.

If the system requirement for the current LineIn is strict, you could try an older release such as The download link on that page does work, I just tried it.


Gale. You suggestion worked to a tee. Thank you so much. botise